Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Server automation framework and application
Ruby Other

This branch is 2 commits ahead, 14674 commits behind puppetlabs:master

fix to my fix *facepalm*.

latest commit c6a9ae0364
Rama Roberts authored
Failed to load latest commit information.
autotest
bin
conf Fix for environments in startup script.
examples
ext Code smell: Two space indentation
lib
man Update man pages and partial doc fix to #3491
sbin
spec
tasks/rake
test
.testseries
CHANGELOG Updated CHANGELOG for 2.6.0rc2
CHANGELOG.old
COPYING
LICENSE Removed extra whitespace from end of lines
README
README.queueing
README.rst
Rakefile maint: Have 'rake spec' output in color
install.rb fix to my fix *facepalm*.

README.rst

Puppet

Puppet, an automated administrative engine for your Linux and Unix systems, performs administrative tasks (such as adding users, installing packages, and updating server configurations) based on a centralized specification.

Documentation (and detailed install instructions) can be found online at the Puppet Documentation site.

Additional documentation can also be found at the Puppet Wiki.

Installation

Generally, you need the following things installed:

  • Ruby >= 1.8.1 (earlier releases might work but probably not)

  • The Ruby OpenSSL library. For some reason, this often isn't included in the main ruby distributions. You can test for it by running 'ruby -ropenssl -e "puts :yep"'. If that errors out, you're missing the library.

    If your distribution doesn't come with the necessary library (e.g., on Debian and Ubuntu you need to install libopenssl-ruby), then you'll probably have to compile Ruby yourself, since it's part of the standard library and not available separately. You could probably just compile and install that one library, though.

  • The Ruby XMLRPC client and server libraries. For some reason, this often isn't included in the main ruby distributions. You can test for it by running 'ruby -rxmlrpc/client -e "puts :yep"'. If that errors out, you're missing the library.

  • Facter => 1.5.1 You can get this from your package management system or the Facter site

Something went wrong with that request. Please try again.