Portable version database #166

Open
iamjaydear opened this Issue Jan 11, 2017 · 5 comments

Projects

None yet

2 participants

@iamjaydear

I want to run the portable version of VC 1.5.33 to do some tests, so I've put it on a Portable Apps USB drive. When I run it it gives me an error that suggests it is seeing newer VC settings on the hard drive. I don't want it to stuff up my v2.44 settings, so how do I get it to run from the USB drive as an isolated, portable app? I expect a portable app to keep ALL of it's settings on the USB drive.

portable_error

@RandomEngy
Owner

v2 portable has the ability to read from VidCoder.sqlite that is right beside the executable. 1.5 always reads from the shared settings in %appdata%\VidCoder .

@iamjaydear

Looks like what I want to do isn't going to be possible. I guess what I don't know is if "version 34 database" belongs to v2.44 or some other 1.5 version? What I'm trying to do is process a sample mpg file using both v2.44 and v1.5.33 on the same PC to see if the audio distortion I've reported in another issue is only present in the mp4 from v2.44. My v2.44 install is not portable and I don't want to stuff it up.

@RandomEngy
Owner

Yeah when you use a later version it automatically upgrades the database. You'd need to swap back to the old database file when changing to v1.5.33.

@iamjaydear
iamjaydear commented Jan 12, 2017 edited

Bummer :( I'll have to do it on two PC's and hope the results are consistent...

@RandomEngy
Owner

No, you just need to switch out the DB files. Or use 2.44 Portable and 1.5.33 installed, then there won't be any conflict.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment