Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix version number requirements #2724

Merged
merged 2 commits into from Jul 3, 2019

Conversation

Projects
None yet
2 participants
@EricFromCanada
Copy link
Contributor

commented Jun 2, 2019

Update dialog to state that the minimum Ubuntu is 16.04 (upon which Linux Mint 18 is based), and set the Debian version to 9 for Ubuntu 16 & 17 / Mint 18 and 10 for Ubuntu 18 & 19 / Mint 19.

This fixes the issue I encountered where the installer would attempt to install ES 2.7.6 instead of stable on Mint 18.3 and Ubuntu 16.04, and fail due to missing Boost libraries.

@EricFromCanada EricFromCanada force-pushed the EricFromCanada:version-numbers branch from da9ca3c to e21b233 Jun 4, 2019

@joolswills

This comment has been minimized.

Copy link
Member

commented Jun 8, 2019

Thanks. Looks ok, but I need to do a few tests.

@joolswills

This comment has been minimized.

Copy link
Member

commented Jul 3, 2019

the PR is fine. apologies for my confusion.

@joolswills joolswills merged commit bb8dc1a into RetroPie:master Jul 3, 2019

@EricFromCanada EricFromCanada deleted the EricFromCanada:version-numbers branch Jul 3, 2019

@@ -84,7 +84,7 @@ function get_os_version() {
__os_release=10
fi

if compareVersions "$__os_debian_ver" lt 8; then
if compareVersions "$__os_debian_ver" lt 9; then

This comment has been minimized.

Copy link
@joolswills

joolswills Jul 12, 2019

Member

This was actually intentional - I will need to revert this part. Although we don't support versions less than 9, we don't stop retropie-setup from launching (the main setup script has an additional warning).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.