Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

raspbiantools - downgrade kernel/firmware instead for stretch bt fix #2765

Merged
merged 1 commit into from Jul 8, 2019

Conversation

Projects
None yet
3 participants
@joolswills
Copy link
Member

commented Jul 7, 2019

  • there are additional issues with the newer kernel including overscan problems
  • add option to pass parameter to apt-mark to hold/unhold and hold downgraded packages

@joolswills joolswills force-pushed the joolswills:downgrade_stretch_kernel branch from 9e34a9d to 35fff7f Jul 7, 2019

@joolswills joolswills changed the title raspbiantools - downgrade package instead for stretch bt fix raspbiantools - downgrade kernel/firmware instead for stretch bt fix Jul 7, 2019

@hhromic

This comment has been minimized.

Copy link
Contributor

commented Jul 7, 2019

Looks good to me. I perhaps would now rename the kernel_bt_fix_raspbiantools() function to something more generic as it is not only fixing bluetooth now :)

@psyke83

This comment has been minimized.

Copy link
Member

commented Jul 8, 2019

Finally I had the opportunity to test the function on my stretch install, before & after this PR.

The 1.20190620+1-1 firmware did fix the PS3 pairing issue - as does this downgrade to 1.20190401-1 . The additional check you added in this PR to not reinstall the same version over and over again seems to be working as intended. Finally, I verified that the latest customhidsony is still working correctly against the 4.14 kernel, so there shouldn't be any issues regarding controllers.

I'm assuming that you'll update the function to remove the package hold after a stable stretch firmware is released?

Considering users' issues with overscan, composite, etc., I've no problem with you merging this. Thanks.

raspbiantools - downgrade firmware/kernel instead for stretch bt fix
 * there are additional issues with the newer kernel including overscan problems
 * add option to pass parameter to apt-mark to hold/unhold and hold downgraded packages

@joolswills joolswills force-pushed the joolswills:downgrade_stretch_kernel branch from 35fff7f to 4d38159 Jul 8, 2019

@joolswills

This comment has been minimized.

Copy link
Member Author

commented Jul 8, 2019

Thanks for the testing.

Yeah. Can unhold when (if?) Stretch gets a new kernel without these issues.

I renamed the function to just stretch_fix_raspbiantools. Will merge.

@joolswills joolswills merged commit 2112ffa into RetroPie:master Jul 8, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.