New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

The GUI is sometimes not drawn #654

Open
hhyyrylainen opened this Issue Dec 20, 2018 · 3 comments

Comments

Projects
None yet
2 participants
@hhyyrylainen
Copy link
Contributor

hhyyrylainen commented Dec 20, 2018

This is perhaps linux specific but sometimes the new CEF GUI just stops drawing. Sometimes resizing the window brings it back but just now when I ran the game for an hour it disappeared the and I couldn't get it back.

This might / is probably be a problem in the engine.

@Untrustedlife

This comment has been minimized.

Copy link
Contributor

Untrustedlife commented Dec 22, 2018

Ive seen the process panel freeze on windows so this isnt linux specific I dont think.

@hhyyrylainen

This comment has been minimized.

Copy link
Contributor

hhyyrylainen commented Dec 22, 2018

I think that's separate issue caused by this (what I mean that sometimes the GUI is completely not redrawn):

[ERROR] [SCRIPT][EXCEPTION] Null pointer access, while running function: AudioSource@ MicrobeStageHudSystem::_playRandomMicrobeAmbience()
	 in function AudioSource@ MicrobeStageHudSystem::_playRandomMicrobeAmbience() defined in /home/hhyyrylainen/Projects/thrive/build/bin/Data/Scripts/microbe_stage/microbe_stage_hud.as(304) ScriptModule(4) GameModule(microbe_stage) ScriptModule, from: ./Data/Scripts/microbe_stage/microbe_stage.levgm
// ------------------ CallStack ------------------ //
	> /home/hhyyrylainen/Projects/thrive/build/bin/Data/Scripts/microbe_stage/microbe_stage_hud.as:304 AudioSource@ MicrobeStageHudSystem::_playRandomMicrobeAmbience()
	> /home/hhyyrylainen/Projects/thrive/build/bin/Data/Scripts/microbe_stage/microbe_stage_hud.as:92 void MicrobeStageHudSystem::handleAmbientSound()
	> /home/hhyyrylainen/Projects/thrive/build/bin/Data/Scripts/microbe_stage/microbe_stage_hud.as:106 void MicrobeStageHudSystem::Run()
[ERROR] Script system(MicrobeStageHudSystem): failed to call Run
@hhyyrylainen

This comment has been minimized.

Copy link
Contributor

hhyyrylainen commented Dec 22, 2018

I made an issue out of that: #663

@hhyyrylainen hhyyrylainen removed this from the 0.4.1 milestone Dec 24, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment