Permalink
Browse files

Merge pull request #1 from michaelgruner/master

Latest code from Michael
  • Loading branch information...
2 parents e6825b9 + f17d494 commit e6bfeb4571da71bfa2bc714ac9f6a9c39c1eab3d @ddompe ddompe committed Sep 6, 2011
Showing with 3,532 additions and 14,735 deletions.
  1. +0 −722 Makefile.in
  2. +0 −13,184 configure
  3. +18 −3 configure.ac
  4. +710 −0 patches/CMEM.patch
  5. +1 −0 patches/series
  6. +14 −4 src/Makefile.am
  7. +0 −562 src/Makefile.in
  8. +10 −0 src/cmem.cfg
  9. +51 −0 src/config.bld
  10. +2 −2 src/gstplugin.c
  11. +39 −0 src/gstusbmessages.h
  12. +505 −80 src/gstusbsink.c
  13. +44 −65 src/gstusbsink.h
  14. +472 −112 src/gstusbsrc.c
  15. +12 −1 src/gstusbsrc.h
  16. +9 −0 src/platformdefs.inc
  17. +921 −0 src/usbgadget.c
  18. +135 −0 src/usbgadget.h
  19. +7 −0 src/usbgadget_descriptors.c
  20. +175 −0 src/usbgadget_descriptors.h
  21. +76 −0 src/usbhost.c
  22. +149 −0 src/usbhost.h
  23. +143 −0 src/usbstring.c
  24. +39 −0 src/usbstring.h
View
Oops, something went wrong.
View
Oops, something went wrong.
View
@@ -7,8 +7,9 @@ dnl required versions of gstreamer and plugins-base
GST_REQUIRED=0.10.16
GSTPB_REQUIRED=0.10.16
-AC_CONFIG_SRCDIR([src/gstplugin.c])
+AC_CONFIG_SRCDIR([src])
AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_FILES([Makefile src/Makefile])
dnl required version of automake
AM_INIT_AUTOMAKE([1.10])
@@ -23,7 +24,8 @@ dnl required version of libtool
LT_PREREQ([2.2.6])
LT_INIT
-dnl give error and exit if we don't have pkgconfig
+
+dnl give error and exit if we don\'t have pkgconfig
AC_CHECK_PROG(HAVE_PKGCONFIG, pkg-config, [ ], [
AC_MSG_ERROR([You need to have pkg-config installed!])
])
@@ -34,6 +36,7 @@ dnl
PKG_CHECK_MODULES(GST, [
gstreamer-0.10 >= $GST_REQUIRED
gstreamer-base-0.10 >= $GST_REQUIRED
+ gstreamer-dataprotocol-0.10 >= $GST_REQUIRED
], [
AC_SUBST(GST_CFLAGS)
AC_SUBST(GST_LIBS)
@@ -47,6 +50,19 @@ PKG_CHECK_MODULES(GST, [
])
])
+
+
+PKG_CHECK_MODULES(LIBUSB, [
+ libusb-1.0
+], [
+ AC_SUBST(LIBUSB_CFLAGS)
+ AC_SUBST(LIBUSB_LIBS)
+], [
+AC_MSG_ERROR([
+ Check for libusb to be installed.
+ ])
+])
+
dnl check if compiler understands -Wall (if yes, add -Wall to GST_CFLAGS)
AC_MSG_CHECKING([to see if compiler understands -Wall])
save_CFLAGS="$CFLAGS"
@@ -70,6 +86,5 @@ dnl set proper LDFLAGS for plugins
GST_PLUGIN_LDFLAGS='-module -avoid-version -export-symbols-regex [_]*\(gst_\|Gst\|GST_\).*'
AC_SUBST(GST_PLUGIN_LDFLAGS)
-AC_CONFIG_FILES([Makefile src/Makefile])
AC_OUTPUT
Oops, something went wrong.

0 comments on commit e6bfeb4

Please sign in to comment.