New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Containers in Multiplayer spawn at 0, 0, 0 for other players #1047

Closed
tritonas00 opened this Issue Jun 9, 2016 · 6 comments

Comments

Projects
None yet
4 participants
@tritonas00
Collaborator

tritonas00 commented Jun 9, 2016

Spawn a container in MP, you see it there fine. But the other players see it at 0, 0, 0 and the rorbot also stays there in crucifixion :P

http://i.imgur.com/OnMInXr.png

Also this sometimes happens with normal vehicles too

https://files.gitter.im/tritonas00/RtT1/2016-06-06-002722_1366x768_scrot.png

@tritonas00 tritonas00 changed the title from Containers in MP spawn at 0, 0, 0 for other players to Containers in Multiplayer spawn at 0, 0, 0 for other players Jun 9, 2016

@ulteq

This comment has been minimized.

Show comment
Hide comment
@ulteq

ulteq Jun 16, 2016

Contributor

This could be solved by including the initial truck position and rotation into the stream setup message:
https://github.com/RigsOfRods/rigs-of-rods/blob/master/source/main/network/protocol/rornet.h#L163-L185

Contributor

ulteq commented Jun 16, 2016

This could be solved by including the initial truck position and rotation into the stream setup message:
https://github.com/RigsOfRods/rigs-of-rods/blob/master/source/main/network/protocol/rornet.h#L163-L185

@only-a-ptr only-a-ptr self-assigned this Aug 23, 2016

@only-a-ptr only-a-ptr added this to the 0.4.7.0 milestone Aug 23, 2016

@only-a-ptr

This comment has been minimized.

Show comment
Hide comment
Member

only-a-ptr commented Aug 23, 2016

@graysonk95

This comment has been minimized.

Show comment
Hide comment
@graysonk95

graysonk95 Sep 3, 2016

The issue with weird things happening at 0,0,0 has been around for as long as I can remember (and I've been using multiplayer since it was "fixed" for v37). This exact issue was especially bad about two or 3 years ago. Whenever I was playing with my private MP group vehicles were spawning at 0,0,0 and we couldn't see each other and all had to keep reloading RoR until we all could see each other and we had to deal with the giant crucified RoRbot.
I'm glad to see this is being worked on.

I made this 0,0,0 issue not too long ago and it has since been closed: #27

graysonk95 commented Sep 3, 2016

The issue with weird things happening at 0,0,0 has been around for as long as I can remember (and I've been using multiplayer since it was "fixed" for v37). This exact issue was especially bad about two or 3 years ago. Whenever I was playing with my private MP group vehicles were spawning at 0,0,0 and we couldn't see each other and all had to keep reloading RoR until we all could see each other and we had to deal with the giant crucified RoRbot.
I'm glad to see this is being worked on.

I made this 0,0,0 issue not too long ago and it has since been closed: #27

@ulteq

This comment has been minimized.

Show comment
Hide comment
@ulteq

ulteq Sep 10, 2016

Contributor

#27 is unrelated to this new issue.

Contributor

ulteq commented Sep 10, 2016

#27 is unrelated to this new issue.

@tritonas00

This comment has been minimized.

Show comment
Hide comment
@tritonas00

tritonas00 Oct 17, 2016

Collaborator

Still valid

Collaborator

tritonas00 commented Oct 17, 2016

Still valid

@ulteq ulteq reopened this Oct 18, 2016

@ulteq ulteq removed this from the 0.4.7.0 milestone Oct 18, 2016

@tritonas00

This comment has been minimized.

Show comment
Hide comment
@tritonas00

tritonas00 Oct 18, 2016

Collaborator

the clients had somewhat different *.zip files.

i downloaded the same as the other player, and the issue resolved.

Collaborator

tritonas00 commented Oct 18, 2016

the clients had somewhat different *.zip files.

i downloaded the same as the other player, and the issue resolved.

@tritonas00 tritonas00 closed this Oct 18, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment