New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Auto-centring commands not working properly #1101

Closed
Aivar-RoR opened this Issue Aug 16, 2016 · 0 comments

Comments

Projects
None yet
2 participants
@Aivar-RoR

Aivar-RoR commented Aug 16, 2016

Auto-centring commands (aka commands with the option 'c' in commands2) are not working properly.
If the command returns back to centre after being used the command sound keeps playing, as if the command is still trying to extend/contract.

Furthermore, commands with the 'c' flag lock up at random, i.e if you extend/contract the command and it returns to center, one of the command keys doesn't work any more. You have to press the other key several times for the command to "unfreeze".

Here is an example commands2 section (from the test rig attached below):

commands2
;id1, id2, rateShort, rateLong, short, long, keys, keyl, options Description
5, 8, 0.5, 0.5, 0.5, 1.5, 1, 2, c extend/contract
3, 9,  0.5, 0.5, 0.5, 1.5, 1, 2, c extend/contract

I prepared a simple box rig to test the bug with.
F1/F2 to slide the beam back and forth.
commandtruck.zip

@Aivar-RoR Aivar-RoR changed the title from Self-centring commands not working properly to Auto-centring commands not working properly Aug 16, 2016

@ulteq ulteq added bug coding labels Aug 16, 2016

@ulteq ulteq added this to the 0.4.7.0 milestone Sep 13, 2016

ulteq added a commit to ulteq/rigs-of-rods that referenced this issue Sep 15, 2016

@ulteq ulteq closed this in #1121 Oct 3, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment