New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Auto-correction of vehicle spawn height. #153

Closed
ghost opened this Issue Apr 10, 2015 · 12 comments

Comments

Projects
None yet
5 participants
@ghost

ghost commented Apr 10, 2015

I have noticed that some vehicles spawn a few feet in the air, sometimes even a few yards, and then when they land, at least about 20 beams are deformed, causing the car to drive slightly to the side at high speeds. Some cars, however, don't have this issue. This should be fixed, and thanks for reading!

@Max98

This comment has been minimized.

Show comment
Hide comment
@Max98

Max98 Apr 11, 2015

Contributor

I believe that this is just a mistake that the modder made while making his mod.
When the n/b isn't at y = 0, the car will spawn few meters in the air, or few meters in the ground.
It would be better if you can give us an example of a car, so I can confirm my theory.

Contributor

Max98 commented Apr 11, 2015

I believe that this is just a mistake that the modder made while making his mod.
When the n/b isn't at y = 0, the car will spawn few meters in the air, or few meters in the ground.
It would be better if you can give us an example of a car, so I can confirm my theory.

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Apr 11, 2015

I see now. One example is pretty much every Gavril car. They always spawn with at least 20 deformed beams, if not more.

And is there a way to change the n/b (wait, what is a n/b?) y position to 0?

ghost commented Apr 11, 2015

I see now. One example is pretty much every Gavril car. They always spawn with at least 20 deformed beams, if not more.

And is there a way to change the n/b (wait, what is a n/b?) y position to 0?

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Apr 28, 2015

Is this topic dead?

ghost commented Apr 28, 2015

Is this topic dead?

@Max98

This comment has been minimized.

Show comment
Hide comment
@Max98

Max98 Apr 29, 2015

Contributor

Nothing is dead when it comes to issue resolving. It's just that we ( @only-a-ptr @Aperion @Hiradur & me ) are pretty busy with few other things for the moment.

Contributor

Max98 commented Apr 29, 2015

Nothing is dead when it comes to issue resolving. It's just that we ( @only-a-ptr @Aperion @Hiradur & me ) are pretty busy with few other things for the moment.

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost commented Apr 29, 2015

Oh, OK.

@only-a-ptr

This comment has been minimized.

Show comment
Hide comment
@only-a-ptr

only-a-ptr Apr 30, 2015

Member

@gigapouch : This is indeed a mistake of the vehicle's authors, like Max98 says. The N/B (nodes & beams) positions were defined too high.

Fixing this by hand is impossible, it would require changing every single node.

However, we may create an optional "height adjuster", which would detect that a truck/car is defined too high ((axle_node_height - wheel_radius) > MAX_HEIGHT) and lower all nodes automatically.

Member

only-a-ptr commented Apr 30, 2015

@gigapouch : This is indeed a mistake of the vehicle's authors, like Max98 says. The N/B (nodes & beams) positions were defined too high.

Fixing this by hand is impossible, it would require changing every single node.

However, we may create an optional "height adjuster", which would detect that a truck/car is defined too high ((axle_node_height - wheel_radius) > MAX_HEIGHT) and lower all nodes automatically.

@only-a-ptr

This comment has been minimized.

Show comment
Hide comment
@only-a-ptr

only-a-ptr May 30, 2015

Member

@Gigapouch: please give us links to some problematic vehicles, with descriptions of the problems. I need it for testing. Thanks.

Member

only-a-ptr commented May 30, 2015

@Gigapouch: please give us links to some problematic vehicles, with descriptions of the problems. I need it for testing. Thanks.

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost May 30, 2015

Here's one (not by Gabester): http://www.rigsofrods.com/threads/106589-2003-Ford-Windstar-LX?highlight=windstar
This one spawns in a way so that the front of the car is way too high, causing the front beams and a few in the back to be deformed, plus the door looks ajar from the inside.

Here's another one (by Gabester): http://www.rigsofrods.com/threads/71461
This one, like most other cars by Gabester (excluding the Burnside series), spawns with at least 25 deformed beams.

ghost commented May 30, 2015

Here's one (not by Gabester): http://www.rigsofrods.com/threads/106589-2003-Ford-Windstar-LX?highlight=windstar
This one spawns in a way so that the front of the car is way too high, causing the front beams and a few in the back to be deformed, plus the door looks ajar from the inside.

Here's another one (by Gabester): http://www.rigsofrods.com/threads/71461
This one, like most other cars by Gabester (excluding the Burnside series), spawns with at least 25 deformed beams.

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Jul 1, 2015

I'm bumping this.

ghost commented Jul 1, 2015

I'm bumping this.

@DirtGamer301

This comment has been minimized.

Show comment
Hide comment
@DirtGamer301

DirtGamer301 Jul 1, 2015

The deforming beams are also from the mod authors (I think) as the same things happen in 0.38/0.4.0.7. It's little things that don't really matter when making a mod and are hard to fix as it takes some time (set_beam_defaults would be required for this, hope I don't give false infos). It's only happening with full flexbody cars, too, as they're more complex.

DirtGamer301 commented Jul 1, 2015

The deforming beams are also from the mod authors (I think) as the same things happen in 0.38/0.4.0.7. It's little things that don't really matter when making a mod and are hard to fix as it takes some time (set_beam_defaults would be required for this, hope I don't give false infos). It's only happening with full flexbody cars, too, as they're more complex.

@only-a-ptr only-a-ptr changed the title from Some vehicles don't spawn correctly. to Auto-correction of vehicle spawn height. Jul 18, 2015

@only-a-ptr only-a-ptr added this to the Post-Nextstable milestone Jul 18, 2015

@only-a-ptr

This comment has been minimized.

Show comment
Hide comment
@only-a-ptr

only-a-ptr Jul 18, 2015

Member

Tools to fine-tune vehicle spawn position will be addes as part of RigEditor - eventually.
Auto-correction of spawn height for existing vehicles may also be implemented - low priority task.

Member

only-a-ptr commented Jul 18, 2015

Tools to fine-tune vehicle spawn position will be addes as part of RigEditor - eventually.
Auto-correction of spawn height for existing vehicles may also be implemented - low priority task.

@Hiradur Hiradur removed this from the Post-Nextstable milestone Oct 24, 2015

@ulteq

This comment has been minimized.

Show comment
Hide comment
@ulteq

ulteq Jan 28, 2016

Contributor

Fixed by: #565

Contributor

ulteq commented Jan 28, 2016

Fixed by: #565

@ulteq ulteq closed this Jan 28, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment