New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

RPM counter doesn't change with the vehicle #223

Closed
DirtGamer301 opened this Issue Jun 1, 2015 · 15 comments

Comments

Projects
None yet
6 participants
@DirtGamer301

DirtGamer301 commented Jun 1, 2015

Depending on the highest RPM of a vehicle, the RPM counter will change to red at the position.

Let's say car A has a RPM of 4500. No problems. Then you spawn car 2 with a RPM of 6000, but the counter will still get red at 4500 RPM.

@Max98 Max98 added the bug label Jun 1, 2015

@Max98 Max98 added this to the RoR 0.4.5 (Nextstable) milestone Jun 1, 2015

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Jun 1, 2015

What's weird with my copy with RoR (0.4.5, test build 3) is that if the redline for the vehicle is say, 3800, the redline of the graphical RPM needle (not in statistics) is 8000.

ghost commented Jun 1, 2015

What's weird with my copy with RoR (0.4.5, test build 3) is that if the redline for the vehicle is say, 3800, the redline of the graphical RPM needle (not in statistics) is 8000.

@only-a-ptr

This comment has been minimized.

Show comment
Hide comment
@only-a-ptr

only-a-ptr Aug 2, 2015

Member

@DirtGamer301 Details! What do you mean by "the RPM counter will change to red?"

Which HUD are you looking at? Does it have needles or just digits? What vehicles are you testing with? Links, please.

Member

only-a-ptr commented Aug 2, 2015

@DirtGamer301 Details! What do you mean by "the RPM counter will change to red?"

Which HUD are you looking at? Does it have needles or just digits? What vehicles are you testing with? Links, please.

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Aug 2, 2015

Wait, there's a digital tachometer now too?

ghost commented Aug 2, 2015

Wait, there's a digital tachometer now too?

@Max98

This comment has been minimized.

Show comment
Hide comment
@Max98

Max98 Aug 2, 2015

Contributor

@gigapouch Yup, there's one, and here's how you can enable it:
image

It's under speed unit. :)

Contributor

Max98 commented Aug 2, 2015

@gigapouch Yup, there's one, and here's how you can enable it:
image

It's under speed unit. :)

@DirtGamer301

This comment has been minimized.

Show comment
Hide comment
@DirtGamer301

DirtGamer301 Aug 2, 2015

@only-a-ptr
I use the standard tachometer, so not the digital one (as I yet didn't fix the ingame settings bug crashing RoR (corrupted config files) as it takes so long).
By "change to red" I mean when the white lines run out and red lines beging in external camera view.

DirtGamer301 commented Aug 2, 2015

@only-a-ptr
I use the standard tachometer, so not the digital one (as I yet didn't fix the ingame settings bug crashing RoR (corrupted config files) as it takes so long).
By "change to red" I mean when the white lines run out and red lines beging in external camera view.

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Aug 3, 2015

Oh, speed unit only says Imperial or Metric. I already use the Digital speedo.

ghost commented Aug 3, 2015

Oh, speed unit only says Imperial or Metric. I already use the Digital speedo.

@Max98 Max98 modified the milestones: Post-Nextstable, RoR 0.4.5 (Nextstable) Aug 11, 2015

@Hiradur Hiradur modified the milestones: Post-Nextstable, 0.4.6.0 Oct 24, 2015

@Hiradur

This comment has been minimized.

Show comment
Hide comment
@Hiradur

Hiradur Nov 22, 2015

Contributor

@DirtGamer301 2 example vehicles please

Contributor

Hiradur commented Nov 22, 2015

@DirtGamer301 2 example vehicles please

@DirtGamer301

This comment has been minimized.

Show comment
Hide comment
@DirtGamer301

DirtGamer301 Nov 22, 2015

It should happen with any vehicle as long as the highrest possible RPM is different.
-Spawn car A with a high RPM
-check the RPM counter
-Spawn car B with low RPM
-Check the RPM counter, it's the old one.
-Leave the game
-Spawn car B
-Check the RPM counter

DirtGamer301 commented Nov 22, 2015

It should happen with any vehicle as long as the highrest possible RPM is different.
-Spawn car A with a high RPM
-check the RPM counter
-Spawn car B with low RPM
-Check the RPM counter, it's the old one.
-Leave the game
-Spawn car B
-Check the RPM counter

@only-a-ptr only-a-ptr self-assigned this Nov 26, 2015

@only-a-ptr

This comment has been minimized.

Show comment
Hide comment
@only-a-ptr

only-a-ptr Nov 26, 2015

Member

@DirtGamer301 Thanks, I'll check it out. Can you please give me links to vehicles you tested with?

Member

only-a-ptr commented Nov 26, 2015

@DirtGamer301 Thanks, I'll check it out. Can you please give me links to vehicles you tested with?

@only-a-ptr only-a-ptr removed this from the 0.4.6.0 milestone Feb 22, 2016

@wilkgr76

This comment has been minimized.

Show comment
Hide comment
@wilkgr76

wilkgr76 Jul 29, 2016

Is this the same thing?

screenshot_2016-07-29_10-40-06_1
(On the right it still says ~300 RPM, on the left 0 RPM)

wilkgr76 commented Jul 29, 2016

Is this the same thing?

screenshot_2016-07-29_10-40-06_1
(On the right it still says ~300 RPM, on the left 0 RPM)

@DirtGamer301

This comment has been minimized.

Show comment
Hide comment
@DirtGamer301

DirtGamer301 Jul 29, 2016

@wilkgr76 It doesn't say 0 on the right, it says 300 (the "3" on the right means 3000, therefore three stripes away from zero it'll be 300). A thing I just noticed on your pic though is the maximum RPM is 4600 but the stripes get red at 6500. however, this seems to be a bug with Burnside itself.
I just tried to reproduce my bug with specific vehicles and don't seem to be able to do so, I must've overseen Petrs message.
I spawned a normal Burnside Sedan.
screenshot_2016-07-29_10-18-39_1
I then spawned a '49 Ford, the RPM display on the right seems to be correct.
screenshot_2016-07-29_10-19-07_1
I spawned a Cherolet S10 Drag, the RPM display on the right changed again and is correct again.
screenshot_2016-07-29_10-20-10_1
So I guess this can be closed. Reopen it if there's further stuff to discuss or someone has the bug again.

DirtGamer301 commented Jul 29, 2016

@wilkgr76 It doesn't say 0 on the right, it says 300 (the "3" on the right means 3000, therefore three stripes away from zero it'll be 300). A thing I just noticed on your pic though is the maximum RPM is 4600 but the stripes get red at 6500. however, this seems to be a bug with Burnside itself.
I just tried to reproduce my bug with specific vehicles and don't seem to be able to do so, I must've overseen Petrs message.
I spawned a normal Burnside Sedan.
screenshot_2016-07-29_10-18-39_1
I then spawned a '49 Ford, the RPM display on the right seems to be correct.
screenshot_2016-07-29_10-19-07_1
I spawned a Cherolet S10 Drag, the RPM display on the right changed again and is correct again.
screenshot_2016-07-29_10-20-10_1
So I guess this can be closed. Reopen it if there's further stuff to discuss or someone has the bug again.

@wilkgr76

This comment has been minimized.

Show comment
Hide comment
@wilkgr76

wilkgr76 Jul 29, 2016

First of all:

@wilkgr76 said: (On the right it still says ~300 RPM)
@DirtGamer301 said: It doesn't say 0 on the right, it says 300 (the "3" on the right means 3000, therefore three stripes away from zero it'll be 300).

That isn't a Burnside:
screenshot_2016-07-30_13-50-40_1

wilkgr76 commented Jul 29, 2016

First of all:

@wilkgr76 said: (On the right it still says ~300 RPM)
@DirtGamer301 said: It doesn't say 0 on the right, it says 300 (the "3" on the right means 3000, therefore three stripes away from zero it'll be 300).

That isn't a Burnside:
screenshot_2016-07-30_13-50-40_1

@disloyalpick

This comment has been minimized.

Show comment
Hide comment
@disloyalpick

disloyalpick Jul 29, 2016

Your porsche is illegal banned content

disloyalpick commented Jul 29, 2016

Your porsche is illegal banned content

@Hiradur

This comment has been minimized.

Show comment
Hide comment
@Hiradur

Hiradur Jul 30, 2016

Contributor

@wilkgr76 Create a new ticket for that, please.

Contributor

Hiradur commented Jul 30, 2016

@wilkgr76 Create a new ticket for that, please.

@wilkgr76

This comment has been minimized.

Show comment
Hide comment
@wilkgr76

wilkgr76 Jul 31, 2016

@Hiradur Will do, just wanted to ask just in case it was the same issue. EDIT: #1091
@disloyalpick I thought all vehicles with inaccurate gauges were illegal & banned from driving on the roads? I thought it was part of checking whether they are allowed to be sold.

wilkgr76 commented Jul 31, 2016

@Hiradur Will do, just wanted to ask just in case it was the same issue. EDIT: #1091
@disloyalpick I thought all vehicles with inaccurate gauges were illegal & banned from driving on the roads? I thought it was part of checking whether they are allowed to be sold.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment