New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Doublesided managedmaterials not working #323

Closed
DirtGamer301 opened this Issue Jul 21, 2015 · 14 comments

Comments

Projects
None yet
8 participants
@DirtGamer301

DirtGamer301 commented Jul 21, 2015

Using TB4 set_managedmaterials_options 1 (doublesided) will lose effect and won't make the material doublesided.

@Max98 Max98 added the bug label Jul 21, 2015

@Max98 Max98 added this to the RoR 0.4.5 (Nextstable) milestone Jul 21, 2015

@Max98 Max98 self-assigned this Jul 21, 2015

@Max98

This comment has been minimized.

Show comment
Hide comment
@Max98

Max98 Jul 21, 2015

Contributor

Can you link me to a mod that has this bug?

Contributor

Max98 commented Jul 21, 2015

Can you link me to a mod that has this bug?

@DirtGamer301

This comment has been minimized.

Show comment
Hide comment
@DirtGamer301

DirtGamer301 Jul 21, 2015

I haven't been trying out with many cars yet, but I can send you an example (Opel Corsa B WIP), or look for another mod having doublesided materials and then send the link (might both take some time).

Mitchieboys Mercedes CLK has them and also Bretts Toyotas, but you will hardly notice anyways on thses vehicles :P

DirtGamer301 commented Jul 21, 2015

I haven't been trying out with many cars yet, but I can send you an example (Opel Corsa B WIP), or look for another mod having doublesided materials and then send the link (might both take some time).

Mitchieboys Mercedes CLK has them and also Bretts Toyotas, but you will hardly notice anyways on thses vehicles :P

@only-a-ptr

This comment has been minimized.

Show comment
Hide comment
@only-a-ptr

only-a-ptr Aug 2, 2015

Member

@DirtGamer301 I need detailed testing instructions: What vehicle to spawn and where to look.

Member

only-a-ptr commented Aug 2, 2015

@DirtGamer301 I need detailed testing instructions: What vehicle to spawn and where to look.

@Max98

This comment has been minimized.

Show comment
Hide comment
@Max98

Max98 Aug 2, 2015

Contributor

@only-a-ptr This is caused by the new managed materials (If I'm not mistaken, might also be a parser bug) I've done, but no one could send me a mod where I can clearly see the problem.

Contributor

Max98 commented Aug 2, 2015

@only-a-ptr This is caused by the new managed materials (If I'm not mistaken, might also be a parser bug) I've done, but no one could send me a mod where I can clearly see the problem.

@DirtGamer301

This comment has been minimized.

Show comment
Hide comment
@DirtGamer301

DirtGamer301 Aug 2, 2015

It's best visible with WIP vehicles using double sided managedmaterials.

It also for example happens with those (and every other car using doublesided managedmaterials):
http://www.rigsofrods.com/threads/116386-1982-1984-Toyota-Hilux-Pickup?p=1383796&viewfull=1#post1383796
http://www.rigsofrods.com/threads/109451-1997-2002-Mercedes-Benz-CLK-%28C208%29

DirtGamer301 commented Aug 2, 2015

It's best visible with WIP vehicles using double sided managedmaterials.

It also for example happens with those (and every other car using doublesided managedmaterials):
http://www.rigsofrods.com/threads/116386-1982-1984-Toyota-Hilux-Pickup?p=1383796&viewfull=1#post1383796
http://www.rigsofrods.com/threads/109451-1997-2002-Mercedes-Benz-CLK-%28C208%29

@DarthCainRor

This comment has been minimized.

Show comment
Hide comment
@DarthCainRor

DarthCainRor Aug 9, 2015

I believe that "set_managedmaterials_options" is causing the issue, as any vehicle I've used it on, now appear one sided as well.

DarthCainRor commented Aug 9, 2015

I believe that "set_managedmaterials_options" is causing the issue, as any vehicle I've used it on, now appear one sided as well.

@Max98 Max98 modified the milestones: Post-Nextstable, RoR 0.4.5 (Nextstable) Aug 11, 2015

@Michael10055

This comment has been minimized.

Show comment
Hide comment
@Michael10055

Michael10055 Aug 13, 2015

Contributor

Since there is no vehicles no really see this bug with, I decided to make a simple cube with all backfaces to best demonstrate this bug.
0.4.0.7:
screenshot_9
0.4.5.0:
screenshot_10
Download for further testing: https://www.dropbox.com/s/y1qzzdlt1f0p9tu/Backface_Cube_Test.zip

Contributor

Michael10055 commented Aug 13, 2015

Since there is no vehicles no really see this bug with, I decided to make a simple cube with all backfaces to best demonstrate this bug.
0.4.0.7:
screenshot_9
0.4.5.0:
screenshot_10
Download for further testing: https://www.dropbox.com/s/y1qzzdlt1f0p9tu/Backface_Cube_Test.zip

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Aug 13, 2015

@DirtGamer301 Why are you using TB 4 and not the official release?

ghost commented Aug 13, 2015

@DirtGamer301 Why are you using TB 4 and not the official release?

@Michael10055

This comment has been minimized.

Show comment
Hide comment
@Michael10055

Michael10055 Aug 13, 2015

Contributor

This issue was originally posted 23 days ago, It still happens in the released build.

Contributor

Michael10055 commented Aug 13, 2015

This issue was originally posted 23 days ago, It still happens in the released build.

@ghost

This comment has been minimized.

Show comment
Hide comment
@ghost

ghost Aug 13, 2015

Whoops, didn't notice the post date.

ghost commented Aug 13, 2015

Whoops, didn't notice the post date.

@graysonk95

This comment has been minimized.

Show comment
Hide comment
@graysonk95

graysonk95 Sep 15, 2015

Screenshot moved from my duplicate issue.
The window glass should have a double-sided material:

screenshot_492e

graysonk95 commented Sep 15, 2015

Screenshot moved from my duplicate issue.
The window glass should have a double-sided material:

screenshot_492e

@Hiradur Hiradur modified the milestones: Post-Nextstable, 0.4.6.0 Oct 24, 2015

@DarthCainRor

This comment has been minimized.

Show comment
Hide comment
@DarthCainRor

DarthCainRor Feb 25, 2016

Hm. I believe this was forgotten about. Think it's a Parser issue

DarthCainRor commented Feb 25, 2016

Hm. I believe this was forgotten about. Think it's a Parser issue

@Michael10055

This comment has been minimized.

Show comment
Hide comment
@Michael10055

Michael10055 Feb 25, 2016

Contributor

It could also be a material issue since @Max98 remade the managedmaterials shader for PSSM.

Contributor

Michael10055 commented Feb 25, 2016

It could also be a material issue since @Max98 remade the managedmaterials shader for PSSM.

@Michael10055

This comment has been minimized.

Show comment
Hide comment
@Michael10055

Michael10055 Apr 15, 2016

Contributor

Anyone looked into this? Seems like a pretty big issue.

Contributor

Michael10055 commented Apr 15, 2016

Anyone looked into this? Seems like a pretty big issue.

@ulteq ulteq added the graphics label Jun 3, 2016

ulteq added a commit to ulteq/rigs-of-rods that referenced this issue Jun 3, 2016

@ulteq ulteq closed this in #1026 Jun 3, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment