New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Beacon Issue #432

Closed
graysonk95 opened this Issue Sep 5, 2015 · 12 comments

Comments

Projects
None yet
5 participants
@graysonk95

graysonk95 commented Sep 5, 2015

Beacons seem to be messed up as of 0.4.5.1.
The lightbar.mesh beacons are now completely synchronized, and colored beacons on other vehicles now default to orange and don't seem to be unsynchronized either:
https://youtu.be/xQHHfAtYfqc

@Max98 Max98 added the bug label Sep 6, 2015

@Max98 Max98 added this to the 0.4.5.2 milestone Sep 6, 2015

@only-a-ptr

This comment has been minimized.

Show comment
Hide comment
@only-a-ptr

only-a-ptr Sep 9, 2015

Member

@graysonk95 I wasn't able to reproduce this. Please describe in detail how you tested it. For me, beacons are broken since 045 - the flares are stuck at the (0,0,0) corner of the map, only sound is working.
screenshot_8

Builds I tested:

My test scenarios:

  • Clear cache (manually delete files)
  • Run ror, select SimpleTestTerrain, load old Dodge Police (that's the vehicle you used, right?) http://www.rigsofrods.com/repository/view/3762
  • Press 'H' (horn/police siren) to activate the lightbar.
Member

only-a-ptr commented Sep 9, 2015

@graysonk95 I wasn't able to reproduce this. Please describe in detail how you tested it. For me, beacons are broken since 045 - the flares are stuck at the (0,0,0) corner of the map, only sound is working.
screenshot_8

Builds I tested:

My test scenarios:

  • Clear cache (manually delete files)
  • Run ror, select SimpleTestTerrain, load old Dodge Police (that's the vehicle you used, right?) http://www.rigsofrods.com/repository/view/3762
  • Press 'H' (horn/police siren) to activate the lightbar.
@DarthCainRor

This comment has been minimized.

Show comment
Hide comment
@DarthCainRor

DarthCainRor Sep 14, 2015

M activates the light bar. H is just the horn. The beacons work in the correct color for me, but they are synchronized, and they didn't used to be.
screenshot_70

DarthCainRor commented Sep 14, 2015

M activates the light bar. H is just the horn. The beacons work in the correct color for me, but they are synchronized, and they didn't used to be.
screenshot_70

@graysonk95

This comment has been minimized.

Show comment
Hide comment
@graysonk95

graysonk95 Sep 15, 2015

I simply spawned the Dodge Police and pressed 'M' for the beacons as I would with any other version.
I used 0.4.5.1, built August 25th (I'm not sure where I can find the build number, the "About" tab in the Configurator doesn't have one so I won't be of much help here).

The beacons on the lightbar.mesh were the correct color, they were just synchronized.
Other vehicles that use individual beacons now only spawn with orange in the version I am using.
The ambulance in my test video has blue beacons, but they spawned as orange ones.

I know the non-orange colored beacon meshes were made/modified by Isaac.Eiland-Hall and were never built-in or pre-packaged with the game.
I would imagine something about the built-in orange beacon is overriding the added colored ones.
(Any vehicles that use a non-orange beacon must include the mesh for it in their zip).

graysonk95 commented Sep 15, 2015

I simply spawned the Dodge Police and pressed 'M' for the beacons as I would with any other version.
I used 0.4.5.1, built August 25th (I'm not sure where I can find the build number, the "About" tab in the Configurator doesn't have one so I won't be of much help here).

The beacons on the lightbar.mesh were the correct color, they were just synchronized.
Other vehicles that use individual beacons now only spawn with orange in the version I am using.
The ambulance in my test video has blue beacons, but they spawned as orange ones.

I know the non-orange colored beacon meshes were made/modified by Isaac.Eiland-Hall and were never built-in or pre-packaged with the game.
I would imagine something about the built-in orange beacon is overriding the added colored ones.
(Any vehicles that use a non-orange beacon must include the mesh for it in their zip).

@only-a-ptr

This comment has been minimized.

Show comment
Hide comment
@only-a-ptr

only-a-ptr Sep 25, 2015

Member

@graysonk95 Post download link to the ambulance, please. I need to see the definitions of those beacon flares.

Technically, a flare is a billboard - geometry (two triangles) and a material (flare texture, transparent). To make new flares, modder must supply a new material and new texture.

The problem may be that RoR fails to load the new material/texture and falls back to defaults. Try looking in RoR.log

Member

only-a-ptr commented Sep 25, 2015

@graysonk95 Post download link to the ambulance, please. I need to see the definitions of those beacon flares.

Technically, a flare is a billboard - geometry (two triangles) and a material (flare texture, transparent). To make new flares, modder must supply a new material and new texture.

The problem may be that RoR fails to load the new material/texture and falls back to defaults. Try looking in RoR.log

@graysonk95

This comment has been minimized.

Show comment
Hide comment
@graysonk95

graysonk95 Oct 29, 2015

The ambulance was made circa v0.34/0.35, I downloaded it in 2010, so I honestly have no idea where to find it individually.

I know it has been reskinned many times and a version is bundled with the map "Starling Island".
http://www.rigsofrods.com/threads/109425-Updated-terrains-for-0-4-0-7?p=1260243&viewfull=1#post1260243

graysonk95 commented Oct 29, 2015

The ambulance was made circa v0.34/0.35, I downloaded it in 2010, so I honestly have no idea where to find it individually.

I know it has been reskinned many times and a version is bundled with the map "Starling Island".
http://www.rigsofrods.com/threads/109425-Updated-terrains-for-0-4-0-7?p=1260243&viewfull=1#post1260243

@only-a-ptr

This comment has been minimized.

Show comment
Hide comment
@only-a-ptr

only-a-ptr Oct 30, 2015

Member

@graysonk95 We need to find some publicly available vehicle to test with.

Try with old Dodge Police http://www.rigsofrods.com/repository/view/3762 (like I did in a post above) or suggest something else.

Member

only-a-ptr commented Oct 30, 2015

@graysonk95 We need to find some publicly available vehicle to test with.

Try with old Dodge Police http://www.rigsofrods.com/repository/view/3762 (like I did in a post above) or suggest something else.

@graysonk95

This comment has been minimized.

Show comment
Hide comment
@graysonk95

graysonk95 Oct 30, 2015

I believe this is the pack the original vehicle is from:
(And as you can see the beacon is blue)
http://www.rigsofrods.com/repository/view/2002
2002

graysonk95 commented Oct 30, 2015

I believe this is the pack the original vehicle is from:
(And as you can see the beacon is blue)
http://www.rigsofrods.com/repository/view/2002
2002

@only-a-ptr

This comment has been minimized.

Show comment
Hide comment
@only-a-ptr

only-a-ptr Nov 17, 2015

Member

Flare coloring resolved - the vehicles from pack http://www.rigsofrods.com/repository/view/2002 now flash blue.

Member

only-a-ptr commented Nov 17, 2015

Flare coloring resolved - the vehicles from pack http://www.rigsofrods.com/repository/view/2002 now flash blue.

@only-a-ptr

This comment has been minimized.

Show comment
Hide comment
@only-a-ptr

only-a-ptr Nov 17, 2015

Member

Resolved!
I still need to tackle the "corner flash" glitch tho.

Member

only-a-ptr commented Nov 17, 2015

Resolved!
I still need to tackle the "corner flash" glitch tho.

@only-a-ptr only-a-ptr closed this Nov 17, 2015

only-a-ptr added a commit to only-a-ptr/rigs-of-rods that referenced this issue Nov 17, 2015

@graysonk95

This comment has been minimized.

Show comment
Hide comment
@graysonk95

graysonk95 Dec 6, 2015

The big flare in the corner of the map glitch has existed for the entire 5+ years I've been here.

I reported it in 0.37.126 on the Redmine... never got fixed.

graysonk95 commented Dec 6, 2015

The big flare in the corner of the map glitch has existed for the entire 5+ years I've been here.

I reported it in 0.37.126 on the Redmine... never got fixed.

@only-a-ptr

This comment has been minimized.

Show comment
Hide comment
@only-a-ptr

only-a-ptr Dec 7, 2015

Member

@graysonk95 ...So it's not anything I broke, but something that's been missing. Thanks, that's a helpful note.

Member

only-a-ptr commented Dec 7, 2015

@graysonk95 ...So it's not anything I broke, but something that's been missing. Thanks, that's a helpful note.

@Hiradur

This comment has been minimized.

Show comment
Hide comment
@Hiradur

Hiradur Jan 23, 2016

Contributor

@only-a-ptr Just stumbled across this: bbcf51c

Contributor

Hiradur commented Jan 23, 2016

@only-a-ptr Just stumbled across this: bbcf51c

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment