New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

make fails with "[...]/source/main/gui/LobbyGUI.h:34:19: error: expected class-name before ‘,’ token" #802

Closed
krichter722 opened this Issue Mar 7, 2016 · 9 comments

Comments

Projects
None yet
2 participants
@krichter722

krichter722 commented Mar 7, 2016

On Ubuntu 15.10 and 16.04 cmake . && make fails with

In file included from /mnt/richtercloud/sources/rigs-of-rods/source/main/gui/LobbyGUI.cpp:23:0:
/mnt/richtercloud/sources/rigs-of-rods/source/main/gui/LobbyGUI.h:34:19: error: expected class-name before ‘,’ token
  public IRCWrapper,
                   ^

experienced with 0.4.5.1-555-gd1d3d0f

@Hiradur

This comment has been minimized.

Show comment
Hide comment
@Hiradur

Hiradur Mar 7, 2016

Contributor

On Ubuntu 15.10 and 16.04 ./configure && make fails with

configure shouldn't work at all, you need to run CMake instead. See the scripts in https://github.com/RigsOfRods/ror-linux-buildscripts/tree/0.4.5.1 for commands to build 0.4.5.1.

Contributor

Hiradur commented Mar 7, 2016

On Ubuntu 15.10 and 16.04 ./configure && make fails with

configure shouldn't work at all, you need to run CMake instead. See the scripts in https://github.com/RigsOfRods/ror-linux-buildscripts/tree/0.4.5.1 for commands to build 0.4.5.1.

@Hiradur

This comment has been minimized.

Show comment
Hide comment
@Hiradur

Hiradur Mar 7, 2016

Contributor

Can you try to build the master branch instead? It buils fine with Xubuntu 15.10 for me. It's also more stable than 0.4.5.1.

Contributor

Hiradur commented Mar 7, 2016

Can you try to build the master branch instead? It buils fine with Xubuntu 15.10 for me. It's also more stable than 0.4.5.1.

@krichter722

This comment has been minimized.

Show comment
Hide comment
@krichter722

krichter722 Mar 7, 2016

experienced with 0.4.5.1-555-gd1d3d0f

That is HEAD of the master branch. See man git describe for details.

krichter722 commented Mar 7, 2016

experienced with 0.4.5.1-555-gd1d3d0f

That is HEAD of the master branch. See man git describe for details.

@Hiradur

This comment has been minimized.

Show comment
Hide comment
@Hiradur

Hiradur Mar 7, 2016

Contributor

That is HEAD of the master branch. See man git describe for details.

Right, my bad.
I have no clue why it doesn't work. Have you done any changes to your setup (compiler, flags ...)?

Contributor

Hiradur commented Mar 7, 2016

That is HEAD of the master branch. See man git describe for details.

Right, my bad.
I have no clue why it doesn't work. Have you done any changes to your setup (compiler, flags ...)?

@krichter722

This comment has been minimized.

Show comment
Hide comment
@krichter722

krichter722 Mar 8, 2016

I have no clue why it doesn't work.

Did you try a fresh clone? Maybe in a freshly installed VirtualBox VM?

Have you done any changes to your setup (compiler, flags ...)?

No. I confirmed with fresh clones on Ubuntu 15.10 desktop and VirtualBox VM and 16.04 desktop.

krichter722 commented Mar 8, 2016

I have no clue why it doesn't work.

Did you try a fresh clone? Maybe in a freshly installed VirtualBox VM?

Have you done any changes to your setup (compiler, flags ...)?

No. I confirmed with fresh clones on Ubuntu 15.10 desktop and VirtualBox VM and 16.04 desktop.

@Hiradur

This comment has been minimized.

Show comment
Hide comment
@Hiradur

Hiradur Mar 8, 2016

Contributor

Did you try a fresh clone? Maybe in a freshly installed VirtualBox VM?

No, I'll see what I can do.
I have another idea though, are you building without SocketW?

Contributor

Hiradur commented Mar 8, 2016

Did you try a fresh clone? Maybe in a freshly installed VirtualBox VM?

No, I'll see what I can do.
I have another idea though, are you building without SocketW?

@Hiradur

This comment has been minimized.

Show comment
Hide comment
@Hiradur

Hiradur Mar 16, 2016

Contributor

@krichter722 I built RoR on a fresh install of Xubuntu 15.10 using https://github.com/RigsOfRods/ror-linux-buildscripts and encountered no problems.
The only way I can see for the error to turn up is to build without SocketW, are you doing that?

Contributor

Hiradur commented Mar 16, 2016

@krichter722 I built RoR on a fresh install of Xubuntu 15.10 using https://github.com/RigsOfRods/ror-linux-buildscripts and encountered no problems.
The only way I can see for the error to turn up is to build without SocketW, are you doing that?

@Hiradur

This comment has been minimized.

Show comment
Hide comment
@Hiradur

Hiradur Jul 3, 2016

Contributor

No response for 3 months -> closing. Feel free to reopen if the issue still exists.

Contributor

Hiradur commented Jul 3, 2016

No response for 3 months -> closing. Feel free to reopen if the issue still exists.

@Hiradur Hiradur closed this Jul 3, 2016

@krichter722

This comment has been minimized.

Show comment
Hide comment
@krichter722

krichter722 Aug 7, 2016

fixed with 0.4.5.1-1064-g9c9a558 on Ubuntu 16.04

krichter722 commented Aug 7, 2016

fixed with 0.4.5.1-1064-g9c9a558 on Ubuntu 16.04

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment