New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Skinzip skin selection unable to select default #818

Closed
AnimosusTheWolf opened this Issue Apr 3, 2016 · 9 comments

Comments

Projects
None yet
5 participants
@AnimosusTheWolf

AnimosusTheWolf commented Apr 3, 2016

When you select a vehicle that has a skinzip(s), if you select any of the skins that are part of a skinzip to preview it, and then select the 'default skin' and click ok it will not load the default skin but the first skin that is listed that is part of a skinzip.

@lexman02

This comment has been minimized.

Show comment
Hide comment
@lexman02

lexman02 Apr 3, 2016

Have you tried a different .skinzip file and what version are you using?

lexman02 commented Apr 3, 2016

Have you tried a different .skinzip file and what version are you using?

@AnimosusTheWolf

This comment has been minimized.

Show comment
Hide comment
@AnimosusTheWolf

AnimosusTheWolf Apr 4, 2016

I've tried it on multiple vehicles with multiple skinzips. Once you click off default skin you can never spawn it with the default skin. This has happened since skinzips were introduced, still happens in 0.4.6

AnimosusTheWolf commented Apr 4, 2016

I've tried it on multiple vehicles with multiple skinzips. Once you click off default skin you can never spawn it with the default skin. This has happened since skinzips were introduced, still happens in 0.4.6

@DirtGamer301

This comment has been minimized.

Show comment
Hide comment
@DirtGamer301

DirtGamer301 Apr 4, 2016

@lexman02 Just as TheWolf said, it happens with every single skinzip and since I used skinzips (just saying it, too, since there was some doubt whether he's right or not).

DirtGamer301 commented Apr 4, 2016

@lexman02 Just as TheWolf said, it happens with every single skinzip and since I used skinzips (just saying it, too, since there was some doubt whether he's right or not).

@lexman02

This comment has been minimized.

Show comment
Hide comment
@lexman02

lexman02 Apr 5, 2016

@DirtGamer301 @AnimosusTheWolf Im going to have to try it because I know the .skinzips that I have work fine but let me check. So I just tested it out and the same thing happened to me and I know the .skinzip file is right because I made it. So its a glitch in the game.

lexman02 commented Apr 5, 2016

@DirtGamer301 @AnimosusTheWolf Im going to have to try it because I know the .skinzips that I have work fine but let me check. So I just tested it out and the same thing happened to me and I know the .skinzip file is right because I made it. So its a glitch in the game.

@DarthCainRor

This comment has been minimized.

Show comment
Hide comment
@DarthCainRor

DarthCainRor Apr 5, 2016

It works fine here.
green one was spawned first.

screenshot_2016-04-05_00-12-53_1

screenshot_2016-04-05_00-16-40_1
yellow was first

DarthCainRor commented Apr 5, 2016

It works fine here.
green one was spawned first.

screenshot_2016-04-05_00-12-53_1

screenshot_2016-04-05_00-16-40_1
yellow was first

@DirtGamer301

This comment has been minimized.

Show comment
Hide comment
@DirtGamer301

DirtGamer301 Apr 5, 2016

@DarthCainRor That's not the error. The problem isn't with spawning something and then spawning another one later, it's when spawning the first one.
For example:
-stock colour is white
-first colour in the skin selector is blue
-second one is green
-third is orange

Select the vehicle with the skinzip, now you can select a skin. If you now spawn the stock skin right away it's alright.
If you however first press on the third skin (or any other one that's not the stock one) and then press on the stock one, spawn the stock one, the game will spawn the first one that's on the list and not stock, in this case blue.

DirtGamer301 commented Apr 5, 2016

@DarthCainRor That's not the error. The problem isn't with spawning something and then spawning another one later, it's when spawning the first one.
For example:
-stock colour is white
-first colour in the skin selector is blue
-second one is green
-third is orange

Select the vehicle with the skinzip, now you can select a skin. If you now spawn the stock skin right away it's alright.
If you however first press on the third skin (or any other one that's not the stock one) and then press on the stock one, spawn the stock one, the game will spawn the first one that's on the list and not stock, in this case blue.

@DarthCainRor

This comment has been minimized.

Show comment
Hide comment
@DarthCainRor

DarthCainRor Apr 6, 2016

Oh,that bug. >.< That ones been around since .38 at least. My bad.

DarthCainRor commented Apr 6, 2016

Oh,that bug. >.< That ones been around since .38 at least. My bad.

@AnimosusTheWolf

This comment has been minimized.

Show comment
Hide comment

AnimosusTheWolf commented Apr 6, 2016

@ulteq ulteq added bug GUI labels Apr 6, 2016

@ulteq

This comment has been minimized.

Show comment
Hide comment
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment