Skip to content
Commits on Jun 22, 2011
  1. use ruby 1.9.2 as default

    committed
  2. update github link

    committed
  3. fix syntax error

    committed
  4. Updating ruby versions

    committed
Commits on Nov 25, 2010
Commits on May 3, 2010
  1. Focusing on ruby_switcher only, but leaving ruby switcher in it's pre…

    committed
    …vious directory so I can pull from upstream
Commits on May 1, 2010
  1. Update readme to remove ruby_185

    Mario Olivio Flores committed
  2. Updating ruby switcher

    Mario Olivio Flores committed
  3. Adding .gitignore

    Mario Olivio Flores committed
Commits on Sep 29, 2009
  1. Add ree-1.8.7 to ruby switcher

    rio517 committed
Commits on Sep 25, 2009
  1. README.markdown syntax fixes

    rio517 committed
  2. Update README with info on ruby_switcher

    rio517 committed
Commits on Sep 24, 2009
  1. show ruby version in the bash prompt

    rio517 committed
  2. Add ruby_185

    rio517 committed
  3. default to ree_186

    rio517 committed
Commits on Aug 27, 2009
  1. @muness
Commits on Aug 26, 2009
  1. @ashebanow

    Force GEM_PATH to match GEM_HOME. On my machine, not doing so meant t…

    ashebanow committed
    …hat all gems
    
    installed in Leopard's ruby implementation were visible to all installed versions
    of ruby, and some of my gems weren't compatible with ruby 1.9
  2. @ashebanow

    Update to install a local copy of rubygems (1.3.5) when installing

    ashebanow committed
    a local copy of ruby. Previously the script relied on the version of
    rubygems installed by Leopard, which didn't feel right to me, especially
    for Ruby 1.9.
Commits on Aug 21, 2009
  1. @jasonrudolph
Commits on Aug 14, 2009
  1. @jasonrudolph

    [ruby_switcher] Install REE gems in dedicated directory

    jasonrudolph committed
    Store REE's gems in ~/.gem/ruby-enterprise/1.8, and leave the system
    gems in ~/.gem/ruby/1.8 to better support gems with native extensions.
    
    See also:
    
      - http://tinyurl.com/l5uh93 - Suggestion from Andrew Montgomery-Hurrell
      - http://tinyurl.com/mdslye - REE docs
  2. @jasonrudolph

    [ruby_switcher] Clear RUBYOPT before installing REE

    jasonrudolph committed
    Fixes bug seen when REE attempts to install rubygems:
    
      ~/.ruby_versions/ruby-enterprise-1.8.6-20090610/bin/ruby: no such file to load -- ubygems (LoadError)
Commits on Aug 9, 2009
  1. @rsanheim

    bug fix for gem path for ruby 1.9.1...

    rsanheim committed
    	- should use the full version string, as it matches the default that gems does and will prevent issues when 192/193 come along...
Commits on Jul 26, 2009
  1. @jasonrudolph
Commits on Jul 23, 2009
  1. @muness

    bug fix for 1.8.7 install

    muness committed
  2. @muness

    cleanup:

    muness committed
    - rename use_ruby_186 to use_leopard_ruby
    - refactor install of ruby from ruby-lang
    - add ruby 1.8.6p369 and 1.8.7p174
Commits on Jul 21, 2009
  1. @muness

    jrubyc should also be executable

    muness committed
  2. @muness

    - jruby nailgun support

    muness committed
     - bugfix to the jruby 1.3.1 installer
  3. add jruby 1.3.1

    Muness Alrubaie committed
Commits on Jul 16, 2009
  1. @rsanheim

    avoid double README's in rmate

    rsanheim committed
Commits on Jul 5, 2009
  1. @rsanheim

    include all markdown files

    rsanheim committed
Something went wrong with that request. Please try again.