Skip to content
RobotlegsJS framework integration with CreateJS
Branch: master
Clone or download
tiagoschenkel Merge pull request #32 from RobotlegsJS/upgrade-dependencies
Update dependencies to latest version 🚀
Latest commit be0b4dc Mar 20, 2019
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.github move general issue template to .github folder Nov 25, 2018
.vscode chore: enable format on save rule Mar 20, 2019
example apply prettier format Mar 20, 2019
src implement integration with createjs Aug 8, 2018
static apply prettier format Mar 20, 2019
test
.auditignore update audit ignore Oct 6, 2018
.editorconfig chore: update editorconfig settings Mar 20, 2019
.gitignore
.istanbul.yml add istanbull config file Aug 8, 2018
.prettierrc
.publishrc add publish-please config file Aug 8, 2018
.travis.yml update travis config Nov 23, 2018
CHANGELOG.md update changelog Mar 20, 2019
LICENSE
README.md update readme Aug 8, 2018
deploy-example.sh add simple deploy-example bash script for deploying examples Dec 22, 2018
karma.conf.js improve performance of karma Nov 23, 2018
package.json chore: improve autoformat script Mar 20, 2019
tsconfig.example.json implement integration with createjs Aug 8, 2018
tsconfig.json
tsconfig.test.json implement integration with createjs Aug 8, 2018
tslint.example.json implement integration with createjs Aug 8, 2018
tslint.json
tslint.test.json implement integration with createjs Aug 8, 2018
webpack.config.js
webpack.example.config.js
yarn.lock

README.md

RobotlegsJS CreateJS Extension

GitHub license Gitter chat Build Status codebeat badge Test Coverage npm version Greenkeeper badge styled with prettier

Integrate RobotlegsJS framework with CreateJS.

Installation

You can get the latest release and the type definitions using NPM:

npm install @robotlegsjs/createjs --save

Or using Yarn:

yarn add @robotlegsjs/createjs

The EaselJS dependency is added as peerDependencies, allowing the final user to choose the desired version of the easeljs library on each project.

The @robotlegsjs/createjs package is compatible with versions between the >=1.0.2 <2 version range of easeljs library.

As example, when you would like to use the version 1.0.2 of easeljs library, you can run:

npm install easeljs@1.0.2 reflect-metadata --save

or

yarn add easeljs@1.0.2 reflect-metadata

Then follow the installation instructions of RobotlegsJS library to complete the setup of your project.

Dependencies

Peer Dependencies

Usage

import { Context, MVCSBundle } from "@robotlegsjs/core";

import { ContextView, CreateJSBundle } from "@robotlegsjs/createjs";

import { MyConfig } from "./config/MyConfig";

import { RobotlegsView } from "./view/RobotlegsView";

export class Game {

    private _canvas: HTMLCanvasElement;
    private _stage: createjs.Stage;

    private _context: Context;

    constructor () {
        this.init();
    }

    private init(): void {
        this._canvas = <HTMLCanvasElement>(document.getElementById("canvas"));
        this._stage = new createjs.Stage(this._canvas);

        this._context = new Context();
        this._context.install(MVCSBundle, CreateJSBundle).
            configure(new ContextView(this._stage)).
            configure(MyConfig).
            initialize();

        // enable touch interactions if supported on the current device:
        createjs.Touch.enable(this._stage);

        // enabled mouse over / out events
        this._stage.enableMouseOver(10);
        this._stage.mouseMoveOutside = true; // keep tracking the mouse even when it leaves the canvas

        let robotlegs: RobotlegsView = new RobotlegsView();

        robotlegs.x = this._canvas.width / 2;
        robotlegs.y = this._canvas.height / 2;

        this._stage.addChild(robotlegs);

        window.addEventListener("resize", this.handleResize.bind(this));
        createjs.Ticker.addEventListener("tick", this.tick.bind(this));
    }

    private handleResize(): void {
        this._stage.update();
    }

    private tick(event: Object): void {
        this._stage.update(event);
    }
}

See full example here

Running the example

Run the following commands to run the example:

npm install
npm start

or:

yarn install
yarn start

License

MIT

You can’t perform that action at this time.