New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update travis rubies use last versions when possible #759

Merged
merged 2 commits into from Apr 4, 2018

Conversation

Projects
None yet
3 participants
@spk
Contributor

spk commented Apr 1, 2018

Hi, just updating travis to last rubies when possible; cheers

@coveralls

This comment has been minimized.

coveralls commented Apr 1, 2018

Coverage Status

Coverage increased (+0.5%) to 99.916% when pulling d548ee4 on spk:update-travis-rubies into 433cb76 on RubyMoney:master.

.travis.yml Outdated
- 2.2
- 2.3
- 2.4
- 2.5.1

This comment has been minimized.

@antstorm

antstorm Apr 3, 2018

Contributor

Why is this different from all the other version definitions?

This comment has been minimized.

@spk

spk Apr 4, 2018

Contributor

Fixed in d548ee4

@antstorm

Judging by the TravisCI logs this approach doesn't seem to work. All the versions resolve to older releases.

spk added some commits Apr 1, 2018

@spk spk force-pushed the spk:update-travis-rubies branch from 661d7e4 to d548ee4 Apr 4, 2018

@spk

This comment has been minimized.

Contributor

spk commented Apr 4, 2018

Nice catch this trick look to work only with 2.0-patchlevel; updated in d548ee4

@antstorm

This comment has been minimized.

Contributor

antstorm commented Apr 4, 2018

@spk looking good now, thanks!

@antstorm antstorm merged commit bb011b7 into RubyMoney:master Apr 4, 2018

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@spk spk deleted the spk:update-travis-rubies branch Apr 29, 2018

AlexWayfer added a commit to AlexWayfer/money that referenced this pull request Aug 29, 2018

Update travis rubies to use last versions when possible (RubyMoney#759)
* Update travis rubies use last versions when possible

* Fix patch level rubies on travis
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment