New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix the build #842

Merged
merged 6 commits into from Jan 7, 2019

Conversation

Projects
None yet
3 participants
@orien
Copy link
Contributor

orien commented Jan 4, 2019

Since Bundler 2.0 was released, the build has failed!

In Travis CI we install the latest version of Bundler (2.0.1), but our gemspec specifies we must use ~> 1.3 which excludes Bundler v2.

To fix this:

  • remove the constraint on the Bundler version from the gemspec (this allows developers to use the Bundler version they desire).
  • Install Bundler 1.17.3 on TravisCI (Bundler v2 requires Ruby >= 2.3. We can bump up to Bundler v2 after we remove the legacy Ruby versions from the build matrix.)

Additionally the latest release of i18n is incompatible with legacy Rubies. For these Rubies the i18n has been pinned to the last known working version: 1.2.0.

orien added some commits Jan 4, 2019

Ensure Bundler version 1.17.3 is installed
For compatibility with legacy Ruby releases
@coveralls

This comment has been minimized.

Copy link

coveralls commented Jan 4, 2019

Coverage Status

Coverage remained the same at 100.0% when pulling 4571521 on orien:bundler-2.0 into d904e71 on RubyMoney:master.

@orien orien force-pushed the orien:bundler-2.0 branch 2 times, most recently from ed219d5 to a366f4e Jan 4, 2019

@orien orien force-pushed the orien:bundler-2.0 branch from a366f4e to ea05b8e Jan 4, 2019

@orien orien changed the title [WIP] Fix the build Fix the build Jan 4, 2019

@orien orien requested a review from antstorm Jan 4, 2019

.travis.yml Outdated
@@ -23,7 +23,7 @@ matrix:
- rvm: rbx-3
fast_finish: true
before_install:
- gem update bundler
- gem install bundler --version 1.17.3

This comment has been minimized.

@antstorm

antstorm Jan 5, 2019

Contributor

perfect, can you please update this to --version '~> 1.17' in order to relax requirements a little bit?

This comment has been minimized.

@orien

orien Jan 7, 2019

Contributor

Change applied in 4571521.

Gemfile Outdated
@@ -12,5 +12,6 @@ elsif RUBY_VERSION =~ /^1/
gem 'tins', '~> 1.6.0'
gem 'term-ansicolor', '< 1.4'
end
gem 'i18n', '1.2.0' if RUBY_VERSION =~ /^2\.[012]/

This comment has been minimized.

@antstorm

antstorm Jan 5, 2019

Contributor

RUBY_VERSION < '2.3' should do the work and include 1.9

This comment has been minimized.

@antstorm

antstorm Jan 5, 2019

Contributor

Also, will this work outside of TravisCI? As far as I remember Gemfile entries were ignored when using a gem

This comment has been minimized.

@orien

orien Jan 7, 2019

Contributor

The Gemfile is used by Bundler, so this will effect TravisCI and developers of the Money gem.

This won't influence the gem once it's released to Rubygems. And nor should it. Project teams should be managing their own dependencies for their Ruby runtime specifics.

This comment has been minimized.

@orien

orien Jan 7, 2019

Contributor

Looks like the Ruby 1.9.3 job is installing i18n v0.9.5 for other reasons.
https://travis-ci.org/RubyMoney/money/jobs/476150499#L522

This comment has been minimized.

@orien

orien Jan 7, 2019

Contributor

Change applied in 42f1745.

orien added some commits Jan 7, 2019

Loosen constraints on Bundler version
We can remove this once we've stopped supporting legacy versions of
Ruby.
@antstorm
Copy link
Contributor

antstorm left a comment

Looking good, thank you @orien!

@antstorm antstorm merged commit da1559d into RubyMoney:master Jan 7, 2019

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@orien orien deleted the orien:bundler-2.0 branch Jan 8, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment