Problem with Run: "No Rakefile found" #14

Closed
dentarg opened this Issue Dec 20, 2012 · 2 comments

Comments

Projects
None yet
3 participants

dentarg commented Dec 20, 2012

I open my project with the subl command. I have a .rb file from my project open and press cmd + r. A new Terminal opens and this is what I get:

Last login: Thu Dec 20 10:23:13 on ttys021
rake 
$ rake                                                           dentarg@pair ~
alias quit='' && cd "/Users/dentarg/work/ios/Hello" && clear
rake aborted!
No Rakefile found (looking for: rakefile, Rakefile, rakefile.rb, Rakefile.rb)
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rake.rb:2377:in `raw_load_rakefile'
(See full trace by running task with --trace)
$ alias quit='' && cd "/Users/dentarg/work/ios/Hello" && clear

Build works fine:

(in /Users/dentarg/work/ios/Hello)
     Build ./build/iPhoneSimulator-6.0-Development
   Compile ./app/app_delegate.rb
    Create ./build/iPhoneSimulator-6.0-Development/Hello.app
      Link ./build/iPhoneSimulator-6.0-Development/Hello.app/Hello
    Create ./build/iPhoneSimulator-6.0-Development/Hello.app/Info.plist
    Create ./build/iPhoneSimulator-6.0-Development/Hello.app/PkgInfo
    Create ./build/iPhoneSimulator-6.0-Development/Hello.dSYM
[Finished in 2.9s]

I'm using Sublime Text 2 Build 2220 and OS X 10.8.2.

Contributor

haraken3 commented Jan 5, 2013

I'm sorry for late reply. I can't reproduce it with Sublime Text 2 Build 2217 and OS X 10.8.2. I will check again later.

Owner

Watson1978 commented Jul 23, 2014

I can't reproduce, so I will close this ticket.
If you still meet the problem, feel free to reopen this ticket.

@Watson1978 Watson1978 closed this Jul 23, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment