Skip to content
express / connect middleware for bootstrap using less.
JavaScript
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
lib
.gitignore
README.md
package.json

README.md

Less Bootstrap Middleware -- Less BS

Express / Connect middleware for bootstrap using less. Adds dependency which uses the bootstrap version which matches the version of this module.

Installation

npm install less-bs-middleware

Usage

Exact same usage as less-middleware.

Example

Just add a stylesheet tag that follows the same pattern as your other stylesheets.

If your stylesheet is:

link(rel='stylesheet', href='/stylesheets/style.css')

Your bootstrap stylesheet tag should be:

link(rel='stylesheet', href='/stylesheets/bootstrap.css')

Express Example:

app.use(require('less-bs-middleware')({ 
    src: __dirname + '/public/less',
    dest: __dirname + '/public/stylesheets',
    prefix: '/stylesheets'
}));
Something went wrong with that request. Please try again.