Update .travis.yml #552

Closed
wants to merge 1 commit into
from

Projects

None yet

2 participants

@michaelklishin

I've previously submitted the same change but it was lost in conflict
resolution by @modialabs-bumblebee.

There is no need to add 10gen repository or install mongodb or JDK in
the travis-ci.org CI env. All VM images have mongodb and one JDK.

All you have to do to be future proof is to make sure it is started
(it is currently started on boot but we will change this in the future).

Michael Klishin Update .travis.yml
I've previously submitted the same change but it was lost in conflict
resolution.

There is no need to add 10gen repository or install mongodb or JDK in
the travis-ci.org CI env. All VM images have mongodb and one JDK.

All you have to do to be future proof is to make sure it is started
(it is currently started on boot but we will change this in the future).
47ed154
@larryweya

@michaelklishin We explicitly setup mongodb from the 10gen repo since we were using querying features that were available on mongodb 1.6+ on ubuntu 10. We're now running ubuntu 12 which has mongo db 2.x but I'm not sure what travis is running. I need to pull you request into a branch and test it on travis.

@michaelklishin

I am one of the travis-ci.org maintainers. Travis uses 2.x from the 10 gen repository.

@larryweya

@michaelklishin Thanks for pointing this out, we've merged in the changes.

@larryweya larryweya closed this Aug 6, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment