New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

No more underlined text on the master version #692

Closed
sywesk opened this Issue Aug 27, 2014 · 10 comments

Comments

Projects
None yet
5 participants
@sywesk

sywesk commented Aug 27, 2014

in the version downloaded the 19th of august, before the "Strikethrough" commit, there is a bug regarding the font system : the text is no more underlined. I haven't tested the latest master, but it seems there was no commit regarding this bug.

@MarioLiebisch

This comment has been minimized.

Show comment
Hide comment
@MarioLiebisch

MarioLiebisch Aug 27, 2014

Member

Any additional specifics like your system, font name, font size, etc.? Or does it matter at all?

Member

MarioLiebisch commented Aug 27, 2014

Any additional specifics like your system, font name, font size, etc.? Or does it matter at all?

@sywesk

This comment has been minimized.

Show comment
Hide comment
@sywesk

sywesk Aug 27, 2014

It doesn't really matter, on the stable 2.1 the same font worked like a charm. But when i decided to use the master, the underline disappeared. Anyway the font is SourceCodePro from Adobe, running on windows 8.1 x64. The program was built with VS 120 in x64 mode. The font size is 13.

sywesk commented Aug 27, 2014

It doesn't really matter, on the stable 2.1 the same font worked like a charm. But when i decided to use the master, the underline disappeared. Anyway the font is SourceCodePro from Adobe, running on windows 8.1 x64. The program was built with VS 120 in x64 mode. The font size is 13.

@LaurentGomila

This comment has been minimized.

Show comment
Hide comment
@LaurentGomila

LaurentGomila Aug 27, 2014

Member

It doesn't really matter

It does, because now the underline thickness is taken from the font, it's not a fixed value anymore. Can you try with a standard font, like Arial for example?

Member

LaurentGomila commented Aug 27, 2014

It doesn't really matter

It does, because now the underline thickness is taken from the font, it's not a fixed value anymore. Can you try with a standard font, like Arial for example?

@sywesk

This comment has been minimized.

Show comment
Hide comment
@sywesk

sywesk Aug 27, 2014

Well, I just tried with arial, and there was no underline too ...
(taken from the windows fonts directory)

sywesk commented Aug 27, 2014

Well, I just tried with arial, and there was no underline too ...
(taken from the windows fonts directory)

@LaurentGomila

This comment has been minimized.

Show comment
Hide comment
@LaurentGomila

LaurentGomila Aug 27, 2014

Member

Ok, thanks.

Let's summon @binary1248 😄

Member

LaurentGomila commented Aug 27, 2014

Ok, thanks.

Let's summon @binary1248 😄

@sywesk

This comment has been minimized.

Show comment
Hide comment
@sywesk

sywesk Aug 27, 2014

Anyway, thanks for the quick replies, i'll wait here and watch the thread ;)

sywesk commented Aug 27, 2014

Anyway, thanks for the quick replies, i'll wait here and watch the thread ;)

@binary1248

This comment has been minimized.

Show comment
Hide comment
@binary1248

binary1248 Aug 28, 2014

Member

Hi, I tried both the revision you mentioned and the current master but could not reproduce a missing underline, even when using Windows' Arial. What I did notice however, was that the underline was not placed correctly. Maybe this has something to do with your underline being completely missing? I don't know...

I fixed that as well as a few other minor things that should make glyphs get rendered as intended (exact pixel size).

You can try the branch at:
https://github.com/LaurentGomila/SFML/tree/bugfix/font_fix

Member

binary1248 commented Aug 28, 2014

Hi, I tried both the revision you mentioned and the current master but could not reproduce a missing underline, even when using Windows' Arial. What I did notice however, was that the underline was not placed correctly. Maybe this has something to do with your underline being completely missing? I don't know...

I fixed that as well as a few other minor things that should make glyphs get rendered as intended (exact pixel size).

You can try the branch at:
https://github.com/LaurentGomila/SFML/tree/bugfix/font_fix

@binary1248 binary1248 added bug labels Aug 28, 2014

@binary1248 binary1248 self-assigned this Aug 28, 2014

@sywesk

This comment has been minimized.

Show comment
Hide comment
@sywesk

sywesk Aug 28, 2014

I tried the branch, it didn't worked. I really don't know what's happening .. I'm trying to build the librairies on my computer instead of my continous integration server and i'll let you know if something changes.

sywesk commented Aug 28, 2014

I tried the branch, it didn't worked. I really don't know what's happening .. I'm trying to build the librairies on my computer instead of my continous integration server and i'll let you know if something changes.

@LaurentGomila

This comment has been minimized.

Show comment
Hide comment
@LaurentGomila

LaurentGomila Aug 28, 2014

Member

Have a look at #693. There's still an issue with small texts (if underline height is < 1 it disappears).

Member

LaurentGomila commented Aug 28, 2014

Have a look at #693. There's still an issue with small texts (if underline height is < 1 it disappears).

@eXpl0it3r

This comment has been minimized.

Show comment
Hide comment
@eXpl0it3r

eXpl0it3r Oct 2, 2014

Member

Fixed in b27cbd5 via #693

Member

eXpl0it3r commented Oct 2, 2014

Fixed in b27cbd5 via #693

@eXpl0it3r eXpl0it3r closed this Oct 2, 2014

@eXpl0it3r eXpl0it3r added s:accepted and removed s:undecided labels Oct 2, 2014

@eXpl0it3r eXpl0it3r added this to the 2.2 milestone Oct 2, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment