Skip to content
Permalink
Browse files

require python3.6

  • Loading branch information
zuntrax committed Jun 27, 2019
1 parent 3bc7954 commit 446fa2d11346e9c53f7eac004cfea8ee352a8d4b
Showing with 9 additions and 9 deletions.
  1. +1 −1 CMakeLists.txt
  2. +2 −2 buildsystem/simple
  3. +2 −2 configure
  4. +1 −1 doc/building.md
  5. +3 −3 openage/__init__.py
@@ -38,7 +38,7 @@ set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON)

# Python and Cython requirements
set(PYTHON_MIN_VERSION 3.4)
set(PYTHON_MIN_VERSION 3.6)
set(CYTHON_MIN_VERSION 0.25)

# CMake policies
@@ -12,8 +12,8 @@
# this script was written by carefully looking at the output of make VERBOSE=1.
# if you add libraries/etc to the project, please update this script accordingly (and test it).

PYVER=3.4m
PYVERDOTLESS=34m
PYVER=3.6m
PYVERDOTLESS=36m
shopt -s globstar

function run() {
@@ -16,8 +16,8 @@ import shutil
import subprocess
import sys

if sys.version_info < (3, 4):
print("openage requires Python 3.4 or higher")
if sys.version_info < (3, 6):
print("openage requires Python 3.6 or higher")
exit(1)


@@ -28,7 +28,7 @@ Dependencies are needed for:
Dependency list:

C gcc >=7 or clang >=5
CRA python >=3.4
CRA python >=3.6
C cython >=0.25
C cmake >=3.8.0
A numpy
@@ -6,15 +6,15 @@
See https://openage.sft.mx and http://github.com/sfttech/openage.
Requires Python 3.4.
Requires Python 3.6.
"""

from sys import version_info as py_version

from .log import setup_logging

if py_version < (3, 4):
raise Exception("openage requires python 3.4 or higher.")
if py_version < (3, 6):
raise Exception("openage requires python 3.6 or higher.")


try:

0 comments on commit 446fa2d

Please sign in to comment.
You can’t perform that action at this time.