Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

LapDelta widget not always in sync with final time posted by iRacing #188

Closed
jfgilliam opened this issue Nov 22, 2018 · 3 comments
Closed

LapDelta widget not always in sync with final time posted by iRacing #188

jfgilliam opened this issue Nov 22, 2018 · 3 comments

Comments

@jfgilliam
Copy link
Contributor

@jfgilliam jfgilliam commented Nov 22, 2018

Steve Kubay: I was doing some test laps @spa this morning. I think, and I'm probably wrong (but this is how it appears to me), the timing discrepancy might come from the fact SRA may not count off track time.

? Maybe?

I spun on 1 lap. 3 or more 100% clean laps previous. When I crossed the stripe, SRA time was 2:20, iracing was 2:29. I would guess that I spent about 9 seconds off track on that spin.

Just talking out loud... Maybe that's something? That would also explain why when you get an Off Track 1x the lap time reported by SRA is a bit quicker than iracing....

image

image

@jfgilliam jfgilliam self-assigned this Nov 22, 2018
@jfgilliam jfgilliam added this to the Version 1.8 milestone Nov 22, 2018
@jfgilliam jfgilliam removed this from the Version 1.8 milestone Dec 9, 2018
@jfgilliam jfgilliam added this to the Version 1.9 milestone Dec 9, 2018
@jfgilliam jfgilliam removed this from the Version 1.9 milestone Mar 3, 2019
@jfgilliam
Copy link
Contributor Author

@jfgilliam jfgilliam commented Apr 4, 2020

image

iRacing Session Best = 2:10.783 +14.389 = 2:25.172
iRacing Last Lap Time = 2:25.172
SRA Projected Lap Time = 2:24.313 ***

Need to check that the Session Best in the telemetry matches the screen

@jfgilliam
Copy link
Contributor Author

@jfgilliam jfgilliam commented Apr 4, 2020

image

iRacing's Best Lap times do not match. Need to figure out if the 2:10 time is in the telemetry somewhere else

@jfgilliam
Copy link
Contributor Author

@jfgilliam jfgilliam commented Apr 4, 2020

The issue is iRacing is using the last clean best lap on the Split's box. The Lap Timing box doesn't care if it's clean.

@jfgilliam jfgilliam added this to the Version 1.13 milestone Apr 4, 2020
jfgilliam added a commit to SIMRacingApps/SIMRacingAppsWebContent that referenced this issue Apr 4, 2020
(SIMRacingApps/SIMRacingApps#188)
       LapDelta widget not always in sync with final time posted by
iRacing
       iRacing was calculating this based on your last clean best lap.
       I was using the best lap on the Lap Timing box, which doesn't
care if it's clean.
       This was only a problem if your best lap wasn't clean.
jfgilliam added a commit to SIMRacingApps/SIMRacingAppsSIMPluginiRacing that referenced this issue Apr 4, 2020
(SIMRacingApps/SIMRacingApps#188)
       LapDelta widget not always in sync with final time posted by
iRacing
       iRacing was calculating this based on your last clean best lap.
       I was using the best lap on the Lap Timing box, which doesn't
care if it's clean.
       This was only a problem if your best lap wasn't clean.
@jfgilliam jfgilliam closed this in edc5606 Apr 6, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant