Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Camera Change Widgit not functional #75

Closed
MirrorImageQS opened this issue Nov 12, 2016 · 6 comments

Comments

@MirrorImageQS
Copy link

commented Nov 12, 2016

The Camera Change widgit does not change to the selected car. Tested in both DX9 and DX11 and both while running the program as administrator and while not.

@jfgilliam jfgilliam added this to the Version 1.2 milestone Nov 12, 2016

@jfgilliam jfgilliam self-assigned this Nov 12, 2016

@jfgilliam

This comment has been minimized.

Copy link
Contributor

commented Nov 12, 2016

Which widget(s)/app(s) did you try?

@MirrorImageQS

This comment has been minimized.

Copy link
Author

commented Nov 13, 2016

2016-11-13 13-16-41.zip
I tried both the one from the Broadcaster,Spotter-CAMERA app and the individual CarSelector-CAMERA widget. Each time, the console did register the command to change car, but the sim did not respond to it.

I also tried moving the logging up to FINEST, but there were no additional messages printed at the time.

EDIT: Actually, I have a correction to this now. It isn't that the widget isn't working at all, it's that it isn't working correctly. I did additional testing and did a screen capture of what I was seeing.
Uploading 2016-11-13 13-16-41.zip…

Based on the log messages and what the screen recording is showing, it appears the code is confusing Car Number (the number on the car and on the app) with the car's actual sim-based ID. From the attached video, for example, I click to change to Car Number 13, but it instead switches me to Car Number 26. It does this for a few other examples as well, which are included in the video. There are also several cases where attempting to switch to a higher numbered car simply does not do anything.

My guess is that the code has essentially transposed CarxID with Car Number in the camera code. The Reference Car updates correctly when using Broadcaster,Spotter-CAMERA, for example.

@jfgilliam

This comment has been minimized.

Copy link
Contributor

commented Nov 13, 2016

Thanks I will test when I get home. in the meantime can you tell me if you can change the camera manually in the session that you're in

  • Jeff

On Nov 13, 2016, at 1:09 PM, MirrorImageQS notifications@github.com wrote:

I tried both the one from the Broadcaster,Spotter-CAMERA app and the individual CarSelector-CAMERA widget. Each time, the console did register the command to change car, but the sim did not respond to it.

I also tried moving the logging up to FINEST, but there were no additional messages printed at the time.


You are receiving this because you were assigned.
Reply to this email directly, view it on GitHub, or mute the thread.

@MirrorImageQS

This comment has been minimized.

Copy link
Author

commented Nov 13, 2016

If by manually you mean the iRacing controls, yes. I can cycle through cars and use the user drop down list in the sim. It is merely the car selection via the widget that is not working.

@jfgilliam

This comment has been minimized.

Copy link
Contributor

commented Nov 14, 2016

Thanks for the video, that helped a lot. I have been able to confirm what you say. All my testing has been done as a spectator in official sessions where the car number and the car index is the same. I got into a practice session and I saw the problem. The camera code wants the car number, not the car index (which is what I was using). I tested that it can work by changing the code to the car number, but I know there's a trick to get it to work with numbers that have a leading zero. The iRacing API wants the car number as an integer. Tomorrow I will search the forum for the math to distinguish between 1, 01, 001.

Thanks again for your help.

@jfgilliam

This comment has been minimized.

Copy link
Contributor

commented Nov 14, 2016

I have fixed this issue and it will be available in the 1.2 release in December 2016. You can get the BETA version of 1.2 now by going to releases and downloading the version with a date greater or equal to 2016.11.14.

@jfgilliam jfgilliam closed this Dec 6, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.