Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't use --hpx:bind=balanced with multiple MPI processes #906

Closed
eschnett opened this issue Oct 1, 2013 · 1 comment

Comments

Projects
None yet
2 participants
@eschnett
Copy link
Contributor

commented Oct 1, 2013

Using multiple MPI processes per node requires the option --hpx:1:pu-offset=8. This cannot be used with --hpx:bind=balanced.

--hpx:bind=balanced should take this pu offset into account in some way (maybe via a different pu offsetting option, maybe by determining the offset automatically), and should then distribute the threads only over a subset of the available pus (here: only over the first 8).

@ghost ghost assigned hkaiser Oct 1, 2013

@hkaiser

This comment has been minimized.

Copy link
Member

commented Oct 1, 2013

This will be solved by closing #421: Support multiple HPX instances per node in a batch environment like PBS or SLURM. Once that's fixed there will be no need to specify --hpx:pu-offset for the second locality anymore. I'm closing this as a duplicate while letting the other ticket refer here.

@hkaiser hkaiser closed this Oct 1, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.