Skip to content


Subversion checkout URL

You can clone with
Download ZIP
Proper MIME type detection library for node.js that wraps the libmagic functionality
Tag: v0.2.4

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.

About still maintained

MIME type detection library for node.js. Unlike the existing mime module, mime-magic does not return the type by interpreting the file extension. Instead it uses the libmagic(3) library which does it properly.

Currently it provides just a simple file(1) wrapper to get the things moving, but in the long run, the purpose of this module is to provide proper node.js libmagic bindings. The file(1) source tree is provided along with this package. It is built during the installation process. The module aims to use the latest available file version along with the up-to-date magic database.

The Windows version of file(1) is bundled with the package. It is a native binary build with MinGW and compressed with UPX.


Either manually clone this repository into your node_modules directory, run make build (under unices), or the recommended method:

npm install mime-magic

Usage mode

var mime = require('mime-magic');

mime.fileWrapper('/path/to/foo.pdf', function (err, type) {
    if (err) {
        console.error(err.message); // ERROR: cannot open `/path/to/foo.pdf' (No such file or directory)
    } else {
        console.log('Detected mime type: %s', type); // application/pdf

Under Windows, you must escape the backslash separators of the path argument:

mime.fileWrapper('C:\\path\\to\\foo.pdf', function (err, type) {
    // do something

You may also pass a path that uses forward slashes as separators:

mime.fileWrapper('C:/path/to/foo.pdf', function (err, type) {
    // do something

Passing relative paths is supported. The fileWrapper uses child_process.execFile() behind the scenes, therefore the err argument contains the information returned by the execFile() method itself plus the error message returned by file(1).


The module was developed under Ubuntu 10.04 and Windows 7. It was tested under OS X Snow Leopard and FreeBSD 8.2. Other platforms may be supported, but the behavior is untested.


  • Felix Chan - #1: couldn't use fileWrapper more than once unless restarted server
Something went wrong with that request. Please try again.