Permalink
Browse files

move periodictable version requirement to 1.5.0

  • Loading branch information...
Paul Kienzle
Paul Kienzle committed Sep 26, 2017
1 parent 0225a3f commit 36ca21e21e4a495fcd26ca357d897051fd52bdb6
@@ -1,11 +1,11 @@
package:
name: periodictable
version: !!str 1.4.1
version: !!str 1.5.0
source:
fn: periodictable-1.4.1.tar.gz
url: https://pypi.python.org/packages/source/p/periodictable/periodictable-1.4.1.tar.gz
md5: 7246b63cc0b6b1be6e86b6616f9e866e
fn: periodictable-1.5.0.tar.gz
url: https://pypi.python.org/packages/source/p/periodictable/periodictable-1.5.0.tar.gz
md5: f7e0d8199b0fe829868d24a0a734398e
# patches:
# List any patch files here
# - fix.patch
@@ -28,7 +28,7 @@ export PYTHONPATH=$PYTHONPATH:$WORKSPACE/utils
"$EASY_INSTALL" -d "$WORKSPACE/utils" lxml
"$EASY_INSTALL" -d "$WORKSPACE/utils" pyparsing==1.5.5
"$EASY_INSTALL" -d "$WORKSPACE/utils" bumps==0.7.5.9
"$EASY_INSTALL" -d "$WORKSPACE/utils" periodictable==1.3.0
"$EASY_INSTALL" -d "$WORKSPACE/utils" periodictable==1.5.0
python deps.py
# Set up working directories
@@ -43,7 +43,7 @@ rm -rf build
# Build SasView ###########################################################
export PYTHONPATH=$PYTHONPATH:$WORKSPACE/$SASVIEW_INSTALL:$WORKSPACE/utils
python setup.py bdist_egg
python setup.py bdist_egg
# Run tests ###############################################################
@@ -7,7 +7,7 @@ html5lib==0.95
reportlab==2.5
lxml==2.3
#PIL==1.1.7
periodictable==1.3.0
periodictable==1.5.0
bumps==0.7.5.9
numpy>=1.7.1
scipy>=0.18.0
View
@@ -26,7 +26,7 @@
'lxml': {'version': '2.3', 'import_name': 'lxml.etree', 'test': 'LXML_VERSION'},
'PIL': {'version': '1.1.7', 'import_name': 'Image', 'test': 'VERSION'},
'pylint': {'version': None, 'import_name': 'pylint', 'test': None},
'periodictable': {'version': '1.3.0', 'import_name': 'periodictable', 'test': '__version__'},
'periodictable': {'version': '1.5.0', 'import_name': 'periodictable', 'test': '__version__'},
'bumps': {'version': '0.7.5.9', 'import_name': 'bumps', 'test': '__version__'},
'numpy': {'version': '1.7.1', 'import_name': 'numpy', 'test': '__version__'},
'scipy': {'version': '0.18.0', 'import_name': 'scipy', 'test': '__version__'},
View
@@ -391,7 +391,7 @@ def append_file(file_list, dir_path):
packages.append("sas.sasview")
required = [
'bumps>=0.7.5.9', 'periodictable>=1.3.1', 'pyparsing<2.0.0',
'bumps>=0.7.5.9', 'periodictable>=1.5.0', 'pyparsing<2.0.0',
# 'lxml>=2.2.2',
'lxml', 'h5py',

0 comments on commit 36ca21e

Please sign in to comment.