Permalink
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
422 lines (421 sloc) 8.75 KB
---
ai4r:
category: ai
description: Artificial intelligence
module: Ai4r
version: "~> 1.13"
algorithms:
category: utilities
description: Algorithms and data structures
module:
- Algorithms
- Containers
version: "~> 0.6"
awesome_print:
category: utilities
description: Pretty object printing
version: "~> 1.6"
bibsync:
category: publishing
description: Bibliography synchronization
module: BibSync
version: "~> 0.0"
bibtex-ruby:
category: publishing
description: BibTeX parser
module: BibTeX
require: bibtex
version: "~> 4.0"
bio:
category: biology
description: Bioinformatics suite
module: Bio
version: "~> 1.4"
cassowary:
category: optimization
description: Incremental constraint solver
exclude: Native dependencies
module: Cassowary
classifier-reborn:
category: ai
description: Machine learning
module: ClassifierReborn
version: "~> 2.0"
cmath:
category: algebra
description: Stdlib cmath module
module: CMath
owner: stdlib
ctioga2:
category: plotting
description: Command line tool for tioga
version: "~> 0.1"
daru:
category: data
description: Dataframe library
module: Daru
version: "~> 0.0"
darwinning:
category: optimization
description: Genetic algorithms
module: Darwinning
version: "~> 0.0"
decisiontree:
category: ai
description: Machine learning
module: DecisionTree
version: "~> 0.5"
distribution:
category: statistics
description: Statistical distributions
module: Distribution
owner: sciruby
version: "~> 0.7"
extendmatrix:
category: algebra
description: Helper methods for Matrix
owner: sciruby
version: "~> 0.4"
gga4r:
category: optimization
description: Genetic algorithms
module: GeneticAlgorithm
version: "~> 0.9"
gimuby:
category: optimization
description: Genetic algorithms
module: Gimuby
version: "~> 0.7"
gnuplot:
category: plotting
description: Plotting library
module: Gnuplot
version: "~> 2.6"
gnuplotrb:
category: plotting
description: Plotting library
module: GnuplotRB
version: "~> 0.2"
gphys:
category: physics
description: Grided physical data
exclude: narray dependency
module: GPhys
gruff:
category: plotting
description: Plotting library
module: Gruff
version: "~> 0.6"
gsl:
category: numerics
description: Bindings for the GNU scientific library
module: GSL
owner: sciruby
version: "~> 2.1"
hamster:
category: utilities
description: Efficient persistent data structures
module:
- Hamster
version: "~> 3.0"
histogram:
category: statistics
description: Histogram method
module: Histogram
version: "~> 0.2"
integration:
category: numerics
description: Numerical integration
module: Integration
owner: sciruby
version: "~> 0.1"
irtruby:
category: ai
description: Machine learning
exclude: Not available as a gem
module: IRT
iruby:
category: ui
description: Ruby kernel for Jupyter
module: IRuby
owner: sciruby
version: "~> 0.2"
liblinear-ruby:
category: ai
description: Linear classifier
module: Liblinear
require: liblinear
version: "~> 1.0"
lpsolve:
category: optimization
description: Linear solver
exclude: Outdated native dependencies
module: LPSolve
mathgl:
category: plotting
description: Plotting library
exclude: Native dependencies
module: MathGL
matrix:
category: algebra
description: Stdlib matrix module
module:
- Matrix
- Vector
owner: stdlib
mdarray:
category: numerics
description: Numerical matrix library
exclude: Requires JRuby
module: MDArray
measurable:
category: ai
description: Distance measures for machine learning
module: Measurable
version: "~> 0.0"
mikon:
category: data
description: Dataframe library
module: Mikon
version: "~> 0.0"
minimization:
category: numerics
description: Numerical minimization
module: Minimization
owner: sciruby
version: "~> 0.2"
mixed_models:
category: statistics
description: Fit statistical models
exclude: Bad version constraints on daru
module: MixedModels
modshogun:
category: ai
description: Machine learning
exclude: Not available as a gem
module: Modshogun
narray:
category: numerics
description: Numerical matrix library
exclude: Conflicts with nmatrix
module: NArray
nmatrix:
category: numerics
description: Numerical matrix library
module:
- N
- NMatrix
- NVector
owner: sciruby
version: "~> 0.2"
nyaplot:
category: plotting
description: Plotting library
module: Nyaplot
version: "~> 0.1"
octave-ruby:
category: numerics
description: Interface to Octave
exclude: Native dependencies
module: Octave
require: octave
ode:
category: numerics
description: Ordinary differential equations
exclude: Fortran dependencies
module: Ode
omoikane:
category: ai
description: Machine learning
exclude: Outdated nmatrix dependency
module: Omoikane
parallel:
category: utilties
description: Parallel processing
module: Parallel
version: "~> 1.6"
phys-units:
category: physics
description: Calculation with units
module:
- Phys::Unit
- Phys::Quantity
require: phys/units
version: "~> 0.9"
plotrb:
category: plotting
description: Plotting library
module: Plotrb
version: "~> 0.0"
plplot:
category: plotting
description: PLplot bindings
exclude: Outdated gem
module: PLplot
prime:
category: algebra
description: Stdlib prime module
module: Prime
owner: stdlib
pry:
category: ui
description: Ruby shell
module: Pry
version: "~> 0.10"
publisci:
category: publishing
description: Publishing toolkit
exclude: Installation fails
module: PubliSci
rb-libsvm:
category: ai
description: Support vector machines (machine learning)
module: Libsvm
require: libsvm
version: "~> 1.3"
rbczmq:
category: ui
description: Needed by iruby
version: "~> 1.7"
rbmetis:
category: graph
description: Graph partitioning
exclude: Native dependencies
module: RbMetis
rinruby:
category: statistics
description: R interpreter
exclude: Outdated gem
module:
- R
- RinRuby
rsemantic:
category: ai
description: Machine learning
exclude: GSL dependency
module: RSemantic
rserve-client:
category: statistics
description: R interpreter
module: Rserve
require: rserve
version: "~> 0.3"
rsruby:
category: statistics
description: R interpreter
exclude: Native dependencies
module: RSRuby
ruby-band:
category: ai
description: Data mining
exclude: Requires JRuby
ruby-dcl:
category: plotting
description: Plotting
exclude: Requires narray
module: NumRu::DCL
ruby-fann:
category: ai
description: Neural networks
module: RubyFann
version: "~> 1.2"
ruby-fftw3:
category: numerics
description: Fast Fourier transformation
exclude: Requires narray
module: FFTW3
ruby-minisat:
category: algebra
description: SAT solver
module: MiniSat
require: minisat
version: "~> 2.2"
ruby-netcdf:
category: data
description: Data file
exclude: Requires narray
module: NumRu::NetCDF
ruby-opencv:
category: ai
description: Computer vision
exclude: Native dependencies
module: OpenCV
require: opencv
ruby-pgplot:
category: plotting
description: Plotting
exclude: Requires narray
module: Pgplot
require: pgplot
rubyvis:
category: plotting
description: Plotting library
module: Rubyvis
version: "~> 0.5"
sciruby:
category: meta
description: SciRuby meta gem
owner: sciruby
sciruby-full:
category: meta
description: SciRuby meta gem (Full installation)
owner: sciruby
statsample:
category: statistics
description: Statistics
module: Statsample
owner: sciruby
version: "~> 2.0"
statsample-bivariate-extension:
category: statistics
description: Statsample extension (Autoloaded)
version: "~> 1.2"
statsample-glm:
category: statistics
description: Statistics
module: Statsample::GLM
owner: sciruby
version: "~> 0.2"
statsample-optimization:
category: statistics
description: Statsample extension (Autoloaded)
exclude: GSL conflict
statsample-sem:
category: statistics
description: Statistics
exclude: Outdated dependencies
module: Statsample::SEM
statsample-timeseries:
category: statistics
description: Statistics
module: Statsample::TimeSeries
version: "~> 0.3"
stuff-classifier:
category: ai
description: Machine learning
exclude: Outdated gem
module: StuffClassifier
symbolic:
category: algebra
description: Symbolic math
exclude: Outdated gem
module: Symbolic
symengine:
category: algebra
description: Symbolic math
exclude: Gem is broken
module: SymEngine
tioga:
category: plotting
description: Scientific plots with PDF and TeX
version: "~> 1.19"
treat:
category: linguistics
description: Natural language processing
exclude: birch doesn't compile with 2.2
module: Treat
unit:
category: physics
description: Calculation with units
module: Unit
version: "~> 0.5"