Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

securityonion-bro-scripts: improve postinst to avoid errors when reinstalling #1711

Closed
dougburks opened this issue Jan 19, 2020 · 4 comments
Closed
Assignees
Projects

Comments

@dougburks
Copy link
Contributor

@dougburks dougburks commented Jan 19, 2020

The postinst script was producing errors when reinstalling via:

sudo apt install --reinstall securityonion-bro-scripts
@dougburks dougburks self-assigned this Jan 19, 2020
@dougburks dougburks added this to To do in 16.04.6.4 via automation Jan 19, 2020
@dougburks dougburks moved this from To do to In progress in 16.04.6.4 Jan 19, 2020
@dougburks

This comment has been minimized.

Copy link
Contributor Author

@dougburks dougburks commented Jan 19, 2020

@dougburks dougburks moved this from In progress to In Testing in 16.04.6.4 Jan 20, 2020
@dougburks

This comment has been minimized.

Copy link
Contributor Author

@dougburks dougburks commented Jan 21, 2020

To test this, install the new package, verify no errors, then reinstall the package via:

sudo apt install --reinstall securityonion-bro-scripts

It should reinstall cleanly with no errors.

@weslambert

This comment has been minimized.

Copy link
Collaborator

@weslambert weslambert commented Jan 23, 2020

No errors when re-installing. 👍

@weslambert weslambert moved this from In Testing to Tested in 16.04.6.4 Jan 23, 2020
@dougburks

This comment has been minimized.

@dougburks dougburks closed this Feb 5, 2020
16.04.6.4 automation moved this from Tested to Done Feb 5, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
16.04.6.4
  
Done
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.