New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

mpi4py (2.0.0) is not compatible with h5py (2.5.0) #11

Closed
chukren opened this Issue Oct 30, 2015 · 5 comments

Comments

Projects
None yet
3 participants
@chukren

chukren commented Oct 30, 2015

The mpi4py.mpi_c has changed to mpi4py.libmpi, so cause the imcompatibility. Current solution is switch to the old version of mpi4py (1.3.x) or make changes in h5py. See discussion at rdhyee/h5py@f2e3f13#diff-c9e1291e5e01f0f5e0a484dccaf67cf6L28


@krischer

This comment has been minimized.

Show comment
Hide comment
@krischer

krischer Oct 30, 2015

Member

Thanks for letting us know. This has to be fixed on the h5py side. I'll put a link to this issue in the pyasd docs.

Member

krischer commented Oct 30, 2015

Thanks for letting us know. This has to be fixed on the h5py side. I'll put a link to this issue in the pyasd docs.

@wjlei1990

This comment has been minimized.

Show comment
Hide comment
@wjlei1990

wjlei1990 Oct 30, 2015

Hi Lion,

That's is the issue we found recently when we use pip to install mpi4py. I think they recently put the default version 1.3.1 to 2.0.0 but h5py is not aware of that.

Should we put a issue on h5py github website?

Hi Lion,

That's is the issue we found recently when we use pip to install mpi4py. I think they recently put the default version 1.3.1 to 2.0.0 but h5py is not aware of that.

Should we put a issue on h5py github website?

@krischer

This comment has been minimized.

Show comment
Hide comment
@krischer

krischer Oct 30, 2015

Member

Should we put a issue on h5py website?

If they are not aware of it then definitely!

Member

krischer commented Oct 30, 2015

Should we put a issue on h5py website?

If they are not aware of it then definitely!

@krischer krischer closed this in b7040a6 Oct 30, 2015

@wjlei1990

This comment has been minimized.

Show comment
Hide comment
@wjlei1990

wjlei1990 Nov 6, 2015

Hi Lion,

I saw the h5py group just update the h5py to be compatible with mpi4py 2.0.0.

See here please.
h5py/h5py@364a774

Can you conform at you end that it is also compatible wiith pyasdf?

Hi Lion,

I saw the h5py group just update the h5py to be compatible with mpi4py 2.0.0.

See here please.
h5py/h5py@364a774

Can you conform at you end that it is also compatible wiith pyasdf?

@krischer

This comment has been minimized.

Show comment
Hide comment
@krischer

krischer Nov 9, 2015

Member

I tried and this works with pyasdf :-)

Member

krischer commented Nov 9, 2015

I tried and this works with pyasdf :-)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment