New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Firefox 57+ Support #24

Closed
rhessinger opened this Issue Oct 9, 2017 · 19 comments

Comments

Projects
None yet
@rhessinger

rhessinger commented Oct 9, 2017

Since Firefox has changed their extension model, can you guys update this to work in the the newer versions of Firefox Developer Edition 57+?

@corevo

This comment has been minimized.

Show comment
Hide comment
@corevo

corevo Oct 9, 2017

Member

Yes, we plan on supporting the webextension standard, specifically firefox and google chrome

Member

corevo commented Oct 9, 2017

Yes, we plan on supporting the webextension standard, specifically firefox and google chrome

@contorax

This comment has been minimized.

Show comment
Hide comment
@contorax

contorax Oct 25, 2017

Please advise how to install and add Selenium IDE to Firefox Developer Edition 57.0b8 or Firefox Quantum 57.0b.11

contorax commented Oct 25, 2017

Please advise how to install and add Selenium IDE to Firefox Developer Edition 57.0b8 or Firefox Quantum 57.0b.11

@zavelevsky

This comment has been minimized.

Show comment
Hide comment
@zavelevsky

zavelevsky Oct 25, 2017

Collaborator

One way to do it now is to run through the extension build process (clone the repo, ran yarn and yarn build), then open Firefox, go to addons, click the settings button and choose debug add-ons, then click to load from a file and navigate to /build/manifest.json

it's a WIP :)

Collaborator

zavelevsky commented Oct 25, 2017

One way to do it now is to run through the extension build process (clone the repo, ran yarn and yarn build), then open Firefox, go to addons, click the settings button and choose debug add-ons, then click to load from a file and navigate to /build/manifest.json

it's a WIP :)

@UsernameIsAlreadyTakenByMe

This comment has been minimized.

Show comment
Hide comment
@UsernameIsAlreadyTakenByMe

UsernameIsAlreadyTakenByMe Nov 4, 2017

Hi, please share the build if it's working :)

UsernameIsAlreadyTakenByMe commented Nov 4, 2017

Hi, please share the build if it's working :)

@corevo

This comment has been minimized.

Show comment
Hide comment
@corevo

corevo Nov 5, 2017

Member

Currently you will have to build it yourself from one of the releases.
We are working on bundling into crx

Member

corevo commented Nov 5, 2017

Currently you will have to build it yourself from one of the releases.
We are working on bundling into crx

@corevo corevo referenced this issue Nov 23, 2017

Merged

WIP: Add Firefox support #51

2 of 2 tasks complete

@corevo corevo closed this Nov 23, 2017

@nischt

This comment has been minimized.

Show comment
Hide comment
@nischt

nischt Dec 5, 2017

When can we expect the selenium build which supports firefox version 57 and above.

nischt commented Dec 5, 2017

When can we expect the selenium build which supports firefox version 57 and above.

@corevo

This comment has been minimized.

Show comment
Hide comment
@corevo

corevo Dec 5, 2017

Member

We are planning on a major release in the very near future.

Member

corevo commented Dec 5, 2017

We are planning on a major release in the very near future.

@nischt

This comment has been minimized.

Show comment
Hide comment
@nischt

nischt Dec 5, 2017

Any rough ETA for that.I was ooking for Python selenium builds

nischt commented Dec 5, 2017

Any rough ETA for that.I was ooking for Python selenium builds

@corevo

This comment has been minimized.

Show comment
Hide comment
@corevo

corevo Dec 5, 2017

Member

I'll update an ETA when I have one, I can say its nearing very fast.
Exporting the IDE project to Selenium python code is not part of this release.

Member

corevo commented Dec 5, 2017

I'll update an ETA when I have one, I can say its nearing very fast.
Exporting the IDE project to Selenium python code is not part of this release.

@nischt

This comment has been minimized.

Show comment
Hide comment
@nischt

nischt Dec 5, 2017

Thanks for the update.
I was actually looking for next package after selenium-3.8.0.tar.gz which has support for Firefox 57 and above.
Hope that will be available.

nischt commented Dec 5, 2017

Thanks for the update.
I was actually looking for next package after selenium-3.8.0.tar.gz which has support for Firefox 57 and above.
Hope that will be available.

@barancev

This comment has been minimized.

Show comment
Hide comment
@barancev

barancev Dec 5, 2017

Member

@nischt Selenium 3.8.0 for python is available:
https://pypi.python.org/pypi/selenium/3.8.0

But why do you ask about this package in IDE subproject?

Member

barancev commented Dec 5, 2017

@nischt Selenium 3.8.0 for python is available:
https://pypi.python.org/pypi/selenium/3.8.0

But why do you ask about this package in IDE subproject?

@nischt

This comment has been minimized.

Show comment
Hide comment
@nischt

nischt Dec 5, 2017

This verison is avaliable but currently it does not have enhancements to support firefox 57.
Thats why I was asking the ETA of this selenium build.

nischt commented Dec 5, 2017

This verison is avaliable but currently it does not have enhancements to support firefox 57.
Thats why I was asking the ETA of this selenium build.

@barancev

This comment has been minimized.

Show comment
Hide comment
@barancev

barancev Dec 5, 2017

Member

@nischt What enhancements do you mean exactly?

Member

barancev commented Dec 5, 2017

@nischt What enhancements do you mean exactly?

@seelamk

This comment has been minimized.

Show comment
Hide comment
@seelamk

seelamk Jan 13, 2018

Me too eagerly waiting for latest IDE for Firefox 57.0x...
Can you suggest with a link to download older Firefox which supports IDE.

seelamk commented Jan 13, 2018

Me too eagerly waiting for latest IDE for Firefox 57.0x...
Can you suggest with a link to download older Firefox which supports IDE.

@98gmarquee

This comment has been minimized.

Show comment
Hide comment
@98gmarquee

98gmarquee Jan 13, 2018

I use 54.0.1 64 bit: https://filehippo.com/download_firefox_64/76360/

Really hoping that when this new version gets built, we can still use the old IDE scripts as I have hundreds that I use for day to day front end testing. In my spare time, I try to learn what I can with selenium core, but the IDE does so much for me and I have so little time to learn/rewrite all my scripts that I will keep a portable version of 54.0.1 as long as I can.

98gmarquee commented Jan 13, 2018

I use 54.0.1 64 bit: https://filehippo.com/download_firefox_64/76360/

Really hoping that when this new version gets built, we can still use the old IDE scripts as I have hundreds that I use for day to day front end testing. In my spare time, I try to learn what I can with selenium core, but the IDE does so much for me and I have so little time to learn/rewrite all my scripts that I will keep a portable version of 54.0.1 as long as I can.

@corevo

This comment has been minimized.

Show comment
Hide comment
@corevo

corevo Jan 13, 2018

Member

You can get the latest Firefox beta here.
We are working on more features from the old IDE, and working on publishing it to Mozilla's Addons Store, in the mean time use that link to install it manually.

Member

corevo commented Jan 13, 2018

You can get the latest Firefox beta here.
We are working on more features from the old IDE, and working on publishing it to Mozilla's Addons Store, in the mean time use that link to install it manually.

@98gmarquee

This comment has been minimized.

Show comment
Hide comment
@98gmarquee

98gmarquee Jan 13, 2018

@corevo Thanks! I didn't realize there was an actual build yet.

The naming convention is odd. But I was able to open a simple html sel script and run some of it. Awesome to see progress!

Wonder what the odds of Samit Badle redoing his additional IDE add-ons. I've come to rely on those as well with the IDE. His highlight is nice so you can see page activity as well as the pause a suite on error vs what the IDE did by default which was fail out of the current script and just starting the next one.

Not sure who made the ide sidebar, but I like that as well vs having it in it's own popup.

Funny how you don't realize how much you rely on something until it's gone.

Great work guys!

98gmarquee commented Jan 13, 2018

@corevo Thanks! I didn't realize there was an actual build yet.

The naming convention is odd. But I was able to open a simple html sel script and run some of it. Awesome to see progress!

Wonder what the odds of Samit Badle redoing his additional IDE add-ons. I've come to rely on those as well with the IDE. His highlight is nice so you can see page activity as well as the pause a suite on error vs what the IDE did by default which was fail out of the current script and just starting the next one.

Not sure who made the ide sidebar, but I like that as well vs having it in it's own popup.

Funny how you don't realize how much you rely on something until it's gone.

Great work guys!

@samitbadle

This comment has been minimized.

Show comment
Hide comment
@samitbadle

samitbadle Jan 29, 2018

Member
Member

samitbadle commented Jan 29, 2018

@bryanl-csi

This comment has been minimized.

Show comment
Hide comment
@bryanl-csi

bryanl-csi Feb 6, 2018

@samitbadle If you start a thread for it, please let me know. I'd like to follow it to see the progress.

Thanks!

Appears I have two users... one for home, one for "work". @98gmarquee is me as well.

bryanl-csi commented Feb 6, 2018

@samitbadle If you start a thread for it, please let me know. I'd like to follow it to see the progress.

Thanks!

Appears I have two users... one for home, one for "work". @98gmarquee is me as well.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment