Official Semantic UI Integration for Ember
Clone or download
championswimmer Merge pull request #232 from Bouke/Bouke-patch-1
Resolve issue with resolving configuration
Latest commit 4cb8b5b May 26, 2018
Permalink
Failed to load latest commit information.
addon move component templates in the addon Mar 15, 2018
app move component templates in the addon Mar 15, 2018
blueprints/semantic-ui-custom fix write line, fix function scope May 9, 2018
config add initial support for custom semantic builds Feb 23, 2018
lib/utils Reorganizing index paths so full path can be customized and passed in… Oct 1, 2016
tape-tests/utils Reorganizing index paths so full path can be customized and passed in… Oct 1, 2016
tests Merge pull request #206 from Dan-Ste/patch-1 Mar 16, 2018
vendor Initial Commit from Ember CLI v0.1.4 Dec 10, 2014
.codeclimate.yml Installing ember-addon-genie Jul 8, 2016
.editorconfig Updating to ember cli to 0.2.5 May 26, 2015
.ember-cli Initial Commit from Ember CLI v0.1.4 Dec 10, 2014
.eslintrc.js Update package.json (#199) Aug 1, 2017
.gitignore semantic-ui-custom blueprint Feb 24, 2018
.npmignore Update package.json (#199) Aug 1, 2017
.nvmrc use ember-promise-utils which uses latest babel Feb 20, 2018
.travis.yml fixup ember-try config as per ember-cli 3.0 spec Feb 20, 2018
.watchmanconfig Upgrading ember cli, and ember to 2.4 Mar 15, 2016
CHANGELOG.md update README and CHANGELOG Feb 17, 2018
LICENSE.md Ember 2 10 (#175) Jan 6, 2017
README.md update README for 3.0 release Mar 9, 2018
ember-cli-build.js update to ember-cli@2.16 and drop bower requirement Feb 17, 2018
index.js Merge pull request #232 from Bouke/Bouke-patch-1 May 25, 2018
package-lock.json 3.0.3 May 10, 2018
package.json Mark walk-sync as a dependency May 17, 2018
testem.js ember-cli 3.0, use headless chrome, drop phantomjs Feb 17, 2018

README.md

Semantic

Semantic-UI-Ember

Build Status npm version Code Climate Codecov Dependency Status

This is the official Ember library for the Semantic-UI modules.

Support

The NodeJS and EmberJS versions respective tags are tested on. It might work with versions not listed as well

3.0

2.1

2.0

Installation

v3

Install this through Ember CLI. We support Ember 2.12 LTS through 3.x

ember install semantic-ui-ember

v2.1

Install this add-on through Ember CLI. We support Ember versions 2.x and above

NOTE: This is a bower-less install

ember install semantic-ui-ember@2.1

That's it.

v2.0 and below only

Install this add-on through Ember CLI. We support Ember versions 1.13 latest - 2.X.

NOTE: Ember 2.x only without fastboot is supported

ember install semantic-ui-ember@2.0

Run the library's blueprint to pull in its Bower dependencies. This only needs to be done once.

ember generate semantic-ui-ember

Documentation

Detailed documentation on using Semantic-UI-Ember.

Changelog