Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

BREAKING(package): require React 16.8 #3733

Merged
merged 1 commit into from Aug 4, 2019
Merged

BREAKING(package): require React 16.8 #3733

merged 1 commit into from Aug 4, 2019

Conversation

@layershifter
Copy link
Member

layershifter commented Aug 4, 2019

BREAKING CHANGES

This PR bumps requirement of React to 16.8. That's all ⭐️


Why?

React 16.8 was released in February, 6 months ago from now. It offered Hooks support which will allow us to simplify existing code and will improve its maintainability. Actually, the main reason is that @stardust-ui/* packages require React 16.8 and to use reuse them we should increase minimal version.

As there are no breaking changes in React versions, update should be straightforward 🚀

@layershifter layershifter changed the title breaking(package): require React 16.8 BREAKING(package): require React 16.8 Aug 4, 2019
@codecov-io

This comment has been minimized.

Copy link

codecov-io commented Aug 4, 2019

Codecov Report

Merging #3733 into master will not change coverage.
The diff coverage is n/a.

Impacted file tree graph

@@           Coverage Diff           @@
##           master    #3733   +/-   ##
=======================================
  Coverage   99.83%   99.83%           
=======================================
  Files         175      175           
  Lines        3124     3124           
=======================================
  Hits         3119     3119           
  Misses          5        5

Continue to review full report at Codecov.

Legend - Click here to learn more
Δ = absolute <relative> (impact), ø = not affected, ? = missing data
Powered by Codecov. Last update 474817d...5cd49ce. Read the comment docs.

@layershifter layershifter merged commit f595fc2 into master Aug 4, 2019
3 of 4 checks passed
3 of 4 checks passed
License Compliance 1 issues found
Details
ci/circleci Your tests passed on CircleCI!
Details
codecov/patch Coverage not affected when comparing 474817d...5cd49ce
Details
codecov/project 99.83% remains the same compared to 474817d
Details
@delete-merged-branch delete-merged-branch bot deleted the chore/bump-react branch Aug 4, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.