Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add `api_version` to ask, askargs API, refs 3038 #3052

Merged
merged 1 commit into from Mar 17, 2018

Conversation

Projects
None yet
3 participants
@mwjames
Copy link
Contributor

commented Mar 3, 2018

This PR is made in reference to: #3038

This PR addresses or contains:

  • Add api_version as parameter to switch versions and in case of api_version=3 means that [ ... ] is used instead of { ... } as outlined in #3038.
  • api_version=2 remains the default and ensures backwards compatibility for any consumer that uses the API

This PR includes:

  • Tests (unit/integration)
  • CI build passed

Fixes: #3038

@mwjames mwjames added the enhancement label Mar 3, 2018

@mwjames mwjames added this to the SMW 3.0.0 milestone Mar 3, 2018

/**
* @var integer
*/
private $serializer_version = 2;

This comment has been minimized.

Copy link
@JeroenDeDauw

JeroenDeDauw Mar 11, 2018

Member

This is not following lowerCamelCase

*
* @param integer $serializer_version
*/
public function serializer_version( $serializer_version ) {

This comment has been minimized.

Copy link
@JeroenDeDauw

JeroenDeDauw Mar 11, 2018

Member

Same here. Also it does not follow the usual verb based method naming scheme.

@mwjames mwjames merged commit 4f6580e into master Mar 17, 2018

2 checks passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
continuous-integration/travis-ci/push The Travis CI build passed
Details

@mwjames mwjames deleted the api branch Mar 17, 2018

@kghbln

This comment has been minimized.

Copy link
Member

commented Jul 28, 2018

Documented for ask and askargs

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.