New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Custom web parts (spfx) are not available from subsites without installing the add-in. #518

Closed
theepan18 opened this Issue Mar 25, 2017 · 3 comments

Comments

Projects
None yet
6 participants
@theepan18

theepan18 commented Mar 25, 2017

Custom web parts (spfx) are not available from subsites without installing the add-in.
Is there any way to install add-in with CSOM?
Or any behavior changes on the way ?

@zplume

This comment has been minimized.

zplume commented Apr 28, 2017

It's not possible currently - see:
#483 (comment)
#344 (comment)

Hopefully tenant-scoped deployment (SPFx equivalent described by Pat in the 2nd link above) will be implemented soon to resolve this...

@mpasarin

This comment has been minimized.

mpasarin commented Dec 22, 2017

Today you have available both ALM API ( https://docs.microsoft.com/en-us/sharepoint/dev/apis/alm-api-for-spfx-add-ins ) and tenant-scope deployment.
I will close the issue as the problem is now resolved.

@mpasarin mpasarin closed this Dec 22, 2017

@RaspeR87

This comment has been minimized.

RaspeR87 commented Apr 26, 2018

If you want to install spfx web parts to subsites for on-prem too please take a look at my blog post -> https://rasper87.wordpress.com/2018/04/26/provision-spfx-web-parts-to-classic-sites-part-3-install-spfx-web-part-to-sharepoint-site-web/

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment