Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

WebPart gives error in Internet Explorer 11, works fine in other browsers. #1042

Closed
YunusGogce opened this issue Oct 24, 2019 · 1 comment
Closed

Comments

@YunusGogce
Copy link

@YunusGogce YunusGogce commented Oct 24, 2019

I have a WebPart that only gives error in IE 11, it works fine in other browsers (Chrome, Edge, Firefox).

Because of this error the WebPart doesn't load at all. I have been trying to fix it for days now and can't find a solution.

ERROR:

[SPLoaderError.loadComponentError]:
***Failed to load component "c2c5687c-1fcf-4e28-83e1-5ce79ffe9968" (BotWebPart). Original error: ***Failed to load entry point from component "c2c5687c-1fcf-4e28-83e1-5ce79ffe9968" (BotWebPart). Original error: Error loading https://component-id.invalid/c2c5687c-1fcf-4e28-83e1-5ce79ffe9968_0.0.1
https://component-id.invalid/c2c5687c-1fcf-4e28-83e1-5ce79ffe9968_0.0.1 did not call System.register or AMD define. If loading a global module configure the global name via the meta exports property for script injection support.

I think that I have found the cause of this error but I'm not 100% sure if it's really the problem. I'm using api-ai-javascript module in my WebPart. When I remove it the WebPart works fine in IE, the problem is that I really need api-ai-javascript to connect to the Google Dialogflow API.

Here is the code that may cause the problem:

import { ApiAiClient } from 'api-ai-javascript';
const accessToken = '......';
const client = new ApiAiClient({accessToken});

So far I've tried pollyfying my BotWebPart.tsx file, no succes. The api-ai-javascript works fine in other browsers and I'm able to make a connection and use the API.

EDIT: I forgot to add that in the developer console of IE 11 i get a SCRIPT1002: Syntax error.

@msftbot

This comment has been minimized.

Copy link

@msftbot msftbot bot commented Oct 24, 2019

Thank you for reporting this issue. We will be triaging your incoming issue as soon as possible.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.