Permalink
Browse files

Use bundler

  • Loading branch information...
1 parent ee071d8 commit 813fa6350223ec7cdff4493d8d64610e8ba22db7 Denis Odorcic committed Aug 19, 2011
Showing with 12 additions and 36 deletions.
  1. +3 −0 Gemfile
  2. +3 −30 Rakefile
  3. +6 −6 test/test_helper.rb
View
@@ -0,0 +1,3 @@
+source :rubygems
+
+gemspec
View
@@ -1,9 +1,9 @@
-require 'rubygems'
+require 'bundler'
+Bundler::GemHelper.install_tasks
+
require 'rake'
require 'rake/testtask'
require 'rake/rdoctask'
-require 'rake/gempackagetask'
-require 'rake/contrib/rubyforgepublisher'
desc "Default Task"
task :default => 'test:units'
@@ -34,30 +34,3 @@ Rake::RDocTask.new do |rdoc|
rdoc.rdoc_files.include('README', 'CHANGELOG')
rdoc.rdoc_files.include('lib/**/*.rb')
end
-
-task :install => [:package] do
- `gem install pkg/#{PKG_FILE_NAME}.gem`
-end
-
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gemspec|
- gemspec.name = 'active_fulfillment'
- gemspec.summary = "Framework and tools for dealing with shipping, tracking and order fulfillment services."
- gemspec.email = "cody@shopify.com"
- gemspec.homepage = "http://github.com/shopify/active_fulfillment"
- gemspec.authors = ["Cody Fauser", "James MacAulay"]
- gemspec.add_dependency('activesupport', '>= 2.3.11')
- gemspec.add_dependency('builder', '>= 2.0.0')
- end
-rescue LoadError
- puts "Jeweler not available. Install it with: gem install jeweler"
-end
-
-desc "Update common files from active_merchant directory"
-task :update_common do
- STDERR.puts "Updating common include from ../active_merchant. Please make sure this is up-to-date"
- system("diff -u lib/active_merchant/common.rb ../active_merchant/lib/active_merchant/common.rb | patch -p0")
- system("diff -ur lib/active_merchant/common ../active_merchant/lib/active_merchant/common | patch -p0")
- STDERR.puts "done.."
-end
View
@@ -1,16 +1,16 @@
#!/usr/bin/env ruby
$:.unshift(File.dirname(__FILE__) + '/../lib')
+require 'rubygems'
+require 'bundler'
+Bundler.setup
+
require 'test/unit'
require 'digest/md5'
require 'active_fulfillment'
+require 'active_utils'
-begin
- require 'mocha'
-rescue LoadError
- require 'rubygems'
- require 'mocha'
-end
+require 'mocha'
module Test
module Unit

0 comments on commit 813fa63

Please sign in to comment.