Permalink
Browse files

Gem version 2.1.0. Don't use Hoe.

  • Loading branch information...
1 parent d87500b commit 5ff699bb8a6258b5d13592e9a253d8df420bdead @jamesmacaulay jamesmacaulay committed Jul 6, 2010
Showing with 8 additions and 16 deletions.
  1. +5 −13 Rakefile
  2. +3 −3 liquid.gemspec
View
18 Rakefile
@@ -1,11 +1,8 @@
#!/usr/bin/env ruby
require 'rubygems'
require 'rake'
-require 'hoe'
-
-PKG_VERSION = "2.0.0"
-PKG_NAME = "liquid"
-PKG_DESC = "A secure non evaling end user template engine with aesthetic markup."
+require 'rake/testtask'
+require 'rake/gempackagetask'
Rake::TestTask.new(:test) do |t|
t.libs << "lib"
@@ -14,16 +11,11 @@ Rake::TestTask.new(:test) do |t|
t.verbose = false
end
-Hoe.new(PKG_NAME, PKG_VERSION) do |p|
- p.rubyforge_name = PKG_NAME
- p.summary = PKG_DESC
- p.description = PKG_DESC
- p.author = "Tobias Luetke"
- p.email = "tobi@leetsoft.com"
- p.url = "http://www.liquidmarkup.org"
+gemspec = eval(File.read('liquid.gemspec'))
+Rake::GemPackageTask.new(gemspec) do |pkg|
+ pkg.gem_spec = gemspec
end
-
namespace :profile do
View
6 liquid.gemspec
@@ -1,11 +1,11 @@
Gem::Specification.new do |s|
s.name = %q{liquid}
- s.version = "2.0.1"
+ s.version = "2.1.0"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Tobias Luetke"]
s.date = %q{2009-04-13}
- s.description = %q{A secure non evaling end user template engine with aesthetic markup.}
+ s.description = %q{A secure, non-evaling end user template engine with aesthetic markup.}
s.email = %q{tobi@leetsoft.com}
s.extra_rdoc_files = ["History.txt", "Manifest.txt", "README.txt"]
s.files = ["CHANGELOG", "History.txt", "MIT-LICENSE", "Manifest.txt", "README.txt", "Rakefile", "lib/extras/liquid_view.rb", "lib/liquid.rb", "lib/liquid/block.rb", "lib/liquid/condition.rb", "lib/liquid/context.rb", "lib/liquid/document.rb", "lib/liquid/drop.rb", "lib/liquid/errors.rb", "lib/liquid/extensions.rb", "lib/liquid/file_system.rb", "lib/liquid/htmltags.rb", "lib/liquid/module_ex.rb", "lib/liquid/standardfilters.rb", "lib/liquid/strainer.rb", "lib/liquid/tag.rb", "lib/liquid/tags/assign.rb", "lib/liquid/tags/capture.rb", "lib/liquid/tags/case.rb", "lib/liquid/tags/comment.rb", "lib/liquid/tags/cycle.rb", "lib/liquid/tags/for.rb", "lib/liquid/tags/if.rb", "lib/liquid/tags/ifchanged.rb", "lib/liquid/tags/include.rb", "lib/liquid/tags/unless.rb", "lib/liquid/template.rb", "lib/liquid/variable.rb"]
@@ -15,7 +15,7 @@ Gem::Specification.new do |s|
s.require_paths = ["lib"]
s.rubyforge_project = %q{liquid}
s.rubygems_version = %q{1.3.1}
- s.summary = %q{A secure non evaling end user template engine with aesthetic markup.}
+ s.summary = %q{A secure, non-evaling end user template engine with aesthetic markup.}
if s.respond_to? :specification_version then
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION

0 comments on commit 5ff699b

Please sign in to comment.