Skip to content
This repository
Fetching contributors…

Cannot retrieve contributors at this time

file 37 lines (31 sloc) 1.492 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37
# -*- encoding: utf-8 -*-
$:.push File.expand_path("../lib", __FILE__)
require "shopify_api/version"

Gem::Specification.new do |s|
  s.name = %q{shopify_api}
  s.version = ShopifyAPI::VERSION
  s.author = "Shopify"

  s.summary = %q{The Shopify API gem is a lightweight gem for accessing the Shopify admin REST web services}
  s.description = %q{The Shopify API gem allows Ruby developers to programmatically access the admin section of Shopify stores. The API is implemented as JSON or XML over HTTP using all four verbs (GET/POST/PUT/DELETE). Each resource, like Order, Product, or Collection, has its own URL and is manipulated in isolation.}
  s.email = %q{developers@jadedpixel.com}
  s.homepage = %q{http://www.shopify.com/partners/apps}

  s.extra_rdoc_files = [
    "LICENSE",
    "README.rdoc"
  ]
  s.files = `git ls-files`.split("\n")
  s.test_files = `git ls-files -- {test}/*`.split("\n")
  s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }

  s.rdoc_options = ["--charset=UTF-8"]
  s.summary = %q{ShopifyAPI is a lightweight gem for accessing the Shopify admin REST web services}
  s.license = 'MIT'

  s.add_dependency("activeresource", [">= 3.0.0"])
  s.add_dependency("thor", [">= 0.14.4"])
  
  if s.respond_to?(:add_development_dependency)
    s.add_development_dependency("mocha", ">= 0.9.8")
    s.add_development_dependency("fakeweb")
  else
    s.add_dependency("mocha", ">= 0.9.8")
    s.add_dependency("fakeweb")
  end
end
Something went wrong with that request. Please try again.