Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Bump version and update changelog #112

Merged
merged 1 commit into from

2 participants

Maarten van Grootel Neil Costford
Maarten van Grootel
Collaborator

Time to release v3.2.0 (minor compatibility breaking change in something added last time).

Updated changelog to match actual changes

review @costford @phoet

Neil Costford
Collaborator

:cool: lots of stuff. Tweet it up!

Maarten van Grootel maartenvg merged commit ab8820e into from
Maarten van Grootel maartenvg deleted the branch
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Jan 22, 2014
  1. Maarten van Grootel
This page is out of date. Refresh to see the latest.
Showing with 12 additions and 7 deletions.
  1. +9 −4 CHANGELOG
  2. +2 −2 Gemfile.lock
  3. +1 −1  lib/shopify_api/version.rb
13 CHANGELOG
View
@@ -1,9 +1,14 @@
-== Version 3.1.9 (Unreleased)
+== Version 3.2.0
* in Session::request_token params is no longer optional, you must pass all the params and the method will now extract the code
-* Add access to FulfillmentService endpoint
-* Fix JSON errors handling (#103)
-* Add convenience method Customer#search (#45)
+* Fixed JSON errors handling (#103)
+* Fixed compatibility with Ruby 2.1.x (#83)
+* Fixed getting parent ID from nested resources like Variants (#44)
+* Cleaned up compatibility with ActiveResource 4.0.x
+* Added OrderRisk resource
+* Added FulfillmentService resource
+* Removed discontinued ProductSearchEngine resource
+* Added convenience method Customer#search (#45)
== Version 3.1.8
4 Gemfile.lock
View
@@ -1,7 +1,7 @@
PATH
remote: .
specs:
- shopify_api (3.1.8)
+ shopify_api (3.2.0)
activeresource (>= 3.0.0)
thor (>= 0.14.4)
@@ -24,7 +24,7 @@ GEM
atomic (1.1.14)
builder (3.1.4)
fakeweb (1.3.0)
- i18n (0.6.5)
+ i18n (0.6.9)
metaclass (0.0.1)
minitest (4.7.5)
mocha (0.14.0)
2  lib/shopify_api/version.rb
View
@@ -1,3 +1,3 @@
module ShopifyAPI
- VERSION = "3.1.8"
+ VERSION = "3.2.0"
end
Something went wrong with that request. Please try again.