Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

SL5 client is not working. it fails to load json.net #1223

Closed
rustd opened this Issue · 4 comments

4 participants

@rustd

When you create a SL5 client and host it inside a webapplication then we get runtime exception where it fails to load JSON.net. Following is the stack trace.

repro
you can get the repro from our share and the project is called webapplication4
run the webapplication first and then the SL web application

stack trace
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET4.0C; .NET4.0E)
Timestamp: Thu, 3 Jan 2013 06:23:50 UTC

Message: Unhandled Error in Silverlight Application Could not load file or assembly 'Newtonsoft.Json, Version=4.5.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified. at Microsoft.AspNet.SignalR.Client.Hubs.HubProxy..ctor(IHubConnection connection, String hubName)
at Microsoft.AspNet.SignalR.Client.Hubs.HubConnection.CreateHubProxy(String hubName)
at SilverlightApplication1.MainPage.Register()
at SilverlightApplication1.MainPage..ctor()
at SilverlightApplication1.App.Application_Startup(Object sender, StartupEventArgs e)
at MS.Internal.CoreInvokeHandler.InvokeEventHandler(UInt32 typeIndex, Delegate handlerDelegate, Object sender, Object args)
at MS.Internal.JoltHelper.FireEvent(IntPtr unmanagedObj, IntPtr unmanagedObjArgs, Int32 argsTypeIndex, Int32 actualArgsTypeIndex, String eventName, UInt32 flags)
Line: 1
Char: 1
Code: 0
URI: http://localhost:26030/SilverlightApplication1TestPage.aspx

@davidfowl
Owner

@rustd can you make the repro accessible outside of corpnet?

@davidfowl
Owner

It might be because the dlls end up in the same folder? The client and server dll for json.net?

@rustd

http://sdrv.ms/S74pRf has the repro

@rustd

I tried to see if JSON.net is being loaded correctly in SL by just having a simple WAP+SL5 application and it was loaded fine

@NTaylorMullen NTaylorMullen was assigned
@halter73 halter73 was assigned
@NTaylorMullen NTaylorMullen was assigned
@halter73 halter73 was assigned
@NTaylorMullen NTaylorMullen was assigned
@halter73 halter73 was assigned
@davidfowl davidfowl was assigned
@halter73 halter73 was assigned
@halter73 halter73 referenced this issue from a commit
@halter73 halter73 Updated Json.NET to version 4.5.11 in all projects.
Json.NET has started strong naming WP Silverlight packages with this version
causing issue #1223.
77d57d1
@halter73 halter73 referenced this issue from a commit
@halter73 halter73 Updated Json.NET to version 4.5.11 in all projects.
Json.NET has started strong naming WP Silverlight packages with this version
causing issue #1223.
8c8960a
@rustd rustd was assigned
@rustd rustd closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.