Take a .NET 4.5 dependency in SignalR core (server side) #1723

Closed
DamianEdwards opened this Issue Mar 20, 2013 · 11 comments

7 participants

@DamianEdwards
SignalR member

Remove support for .NE 4.0 in SignalR server side, allowing us to utilize async/await, etc.

@davidfowl davidfowl was assigned Apr 18, 2013
@davidfowl davidfowl added a commit that referenced this issue Apr 20, 2013
@davidfowl davidfowl Move the server to .NET 4.5 only.
- Removed Owin and SystemWeb 4.0 projects
- Updated related 4.0 only projects to .NET 4.5
#1723
d20b2a8
@davidfowl davidfowl added a commit that referenced this issue Apr 20, 2013
@davidfowl davidfowl Move the server to .NET 4.5 only.
- Removed Owin and SystemWeb 4.0 projects
- Updated related 4.0 only projects to .NET 4.5
#1723
ed065fd
@Xiaohongt Xiaohongt was assigned May 11, 2013
@Xiaohongt
SignalR member

SignalR core symbols package is not .Net 4.5 only yet

@Xiaohongt
SignalR member

Close this for SignalR core package .Net 4.5 only

@Xiaohongt Xiaohongt closed this May 15, 2013
@nipunas

Is this mean, you cannot use SignalR with ASP.NET 4.0?

@davidfowl
SignalR member

@nipunasilva yes, it means that SignalR 2.0 cannot be used with .NET 4.0

@nZeus

It's a pity. It would be better to have 2 assemblies - one for .net 4.5, and another for .net 4.0.
What is the latest version that supports .net 4.0?

@davidfowl
SignalR member

1.2.x still supports .NET 4.0

@Xiaohongt
SignalR member

@nZeus , SignalR 1.x supports .net 4.0, the latest version for 1.x is 1.2.2, you can find the latest 1.x version on http://www.nuget.org/packages/Microsoft.AspNet.SignalR

@nZeus

You're right!
Thanks!

@joepwijers

Yes 1.2.2 works

@simquad

I'm trying to install SignalR using v1.1.4 and is complaining about Microsoft.Owin.Security 2.1.0 not supporting .NET 4.0..... This seems crazy?

Am I missing something obvious?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment