SignalR ServiceBus 1.2 package dependency WindowsAzure.ServiceBus should not >=2.0.1 #2761

Closed
Xiaohongt opened this Issue Dec 12, 2013 · 4 comments

Projects

None yet

2 participants

@Xiaohongt
Contributor

Currently SignalR ServiceBus 1.2 package dependency WindowsAzure.ServiceBus>=2.0.1
WindowsAzure.ServiceBus 2.1.0 the assembly version is Microsoft.ServiceBus, Version=2.0.0.0

But in SignalR ServiceBus source, it uses WindowsAzure.ServiceBus 2.1.3 which assembly version is Microsoft.ServiceBus, Version=2.1.0.0

With WindowsAzure.ServiceBus 2.0.1, SignalR ServiceBus 1.2 will throw error that Could not load Microsoft.ServiceBus, Version=2.1.0.0
So probably SignalR ServiceBus 1.2 package dependency WindowsAzure.ServiceBus should >=2.1.3

@halter73
Member

I fixed this in TFS since the 1.x branch doesn't have the nuspecs checked into git.

@halter73 halter73 was assigned Dec 14, 2013
@Xiaohongt
Contributor

In SignalR ServiceBus 2.0.2, dependency WindowsAzure.ServiceBus is >=2.1.0
@davidfowl confirmed that SignalR ServiceBus 1.2 dependency WindowsAzure.ServiceBus min version should be same as in SignalR ServiceBus 2.0.2
So SignalR ServiceBus 1.2 dependency WindowsAzure.ServiceBus need to be updated to >=2.1.0

@halter73
Member

I changed the ServiceBus dependency to 2.1.0 to match the dependency SignalR 2.0.2 will take.

@Xiaohongt Xiaohongt was assigned Dec 14, 2013
@Xiaohongt
Contributor

verified

@Xiaohongt Xiaohongt closed this Dec 15, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment