Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

on IE10/9 foreverFrame transport connection can't receive message after network disconnect time and network re-connect #820

Closed
Xiaohongt opened this Issue Oct 18, 2012 · 5 comments

Comments

Projects
None yet
2 participants
Contributor

Xiaohongt commented Oct 18, 2012

open IE10 or IE9, use foreverFrame transport for reuqest, disconnect the network cable > 2 minute and then re-connect the network cable, on client processMessages can't receive message anymore

Contributor

NTaylorMullen commented Oct 20, 2012

I'm unable to repro

@ghost ghost assigned NTaylorMullen Oct 21, 2012

Contributor

Xiaohongt commented Oct 25, 2012

not repro now, probably it become fixed when fix other issues

@Xiaohongt Xiaohongt closed this Oct 25, 2012

@Xiaohongt Xiaohongt reopened this Nov 26, 2012

Contributor

Xiaohongt commented Nov 26, 2012

now this repro on both IE9 and IE10

Contributor

NTaylorMullen commented Nov 29, 2012

I was able to repro this a single time but there wasn't anything too funky in the logs:

https://skydrive.live.com/redir?resid=287EB1C9DCE2389B!215&authkey=!ABLuMWUohtZ1Eqg

Tried multiple times to repro it again and could never do it.

@ghost ghost assigned Xiaohongt Nov 30, 2012

Contributor

Xiaohongt commented Dec 14, 2012

now we already changed to client stop the connection after disconnect timeout, this issue doesn't matter anymore

@Xiaohongt Xiaohongt closed this Dec 14, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment