Skip to content


Subversion checkout URL

You can clone with
Download ZIP


Could you support .NET 3.5 #96

donamk opened this Issue · 4 comments

3 participants


Please support .NET 3.5 Please Q.Q.
There is any intent for this?


No. We use the TPL all over the place and hubs makes extension use of C#'s dynamic. Of course it's technically possible, but it's not a goal.

@davidfowl davidfowl closed this

I know this issue is very old by now, but to help people finding this answer I can at least offer some hope. If you have a look in my fork at you can find a client compatible with .net 2.0. No public nuget on that client though. (The fork contains other minor modifications as well: Strong naming for assemblies and an automatic swithover to use POST from .net clients if the client is included in more than 20 groups.)


Why not do it in a way that it can be contributed back to the project. As in adding #if NET20 and do some logic in there. That way, we can take it in and ship the nuget package with that support. It's the really the server that's harder to convert.


Would love to contribute to the project, so I can have a go at it. Wll get back with a pull request when I have something.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.