Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Fixed #501 #562

Closed
wants to merge 1 commit into from

1 participant

@NTaylorMullen
Collaborator

Fixed Connect/Disconnect events not firing in IE. Issue was browser
caching bug, but was fixed by setting the src tag of hte iFrame to
nothing.

#501

@NTaylorMullen NTaylorMullen Fixed Issue #501
Fixed Connect/Disconnect events not firing in IE.  Issue was browser
caching bug, but was fixed by setting the src tag of hte iFrame to
nothing.
7b41733
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Jul 25, 2012
  1. @NTaylorMullen

    Fixed Issue #501

    NTaylorMullen authored
    Fixed Connect/Disconnect events not firing in IE.  Issue was browser
    caching bug, but was fixed by setting the src tag of hte iFrame to
    nothing.
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  SignalR.Client.JS/jquery.signalR.transports.foreverFrame.js
View
2  SignalR.Client.JS/jquery.signalR.transports.foreverFrame.js
@@ -19,7 +19,7 @@
frameId = (transportLogic.foreverFrame.count += 1),
url,
connectTimeOut,
- frame = $("<iframe data-signalr-connection-id='" + connection.id + "' style='position:absolute;top:0;left:0;width:0;height:0;visibility:hidden;'></iframe>");
+ frame = $("<iframe data-signalr-connection-id='" + connection.id + "' style='position:absolute;top:0;left:0;width:0;height:0;visibility:hidden;' src=''></iframe>");
if (window.EventSource) {
// If the browser supports SSE, don't use Forever Frame
Something went wrong with that request. Please try again.