Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ssi_recentTopics generated links to new posts does not work correctly #5548

Open
Bopske opened this issue Mar 27, 2019 · 4 comments

Comments

Projects
None yet
4 participants
@Bopske
Copy link

commented Mar 27, 2019

Description

ssi_recentTopics in SSI.php in 2.1 is generating links to new messages that do not link to the correct post.

Compared to the SSI function in 2.0 the 2.1 SSI function drops you on the first message on the page that holds the new post...

Unread link SMF:
https://myforum.com/index.php?topic=23259.msg327172;topicseen#new

Href link from ssi_recentTopics:
https://myforum.com/index.php?topic=23259.msg327173;topicseen#new

Environment (complete as necessary)

  • Version/Git revision: SMF RC1 last_commit_2802e3a
  • Database Type:
  • Database Version:
  • PHP Version: 7.1

Additional information/references

When on the page and hit 'Refresh' the page does position to the correct post.
Symptom very similar to #5477

@live627 live627 added this to the RC3 milestone Mar 29, 2019

@Bopske

This comment has been minimized.

Copy link
Author

commented Mar 29, 2019

Just checked and tested the solution provided here... #5478 , unfortunately thas fix does not solve the occurrence from SSI (af far as I can see)...

@live627 live627 added the Topics label Mar 31, 2019

@SychO9

This comment has been minimized.

Copy link
Member

commented May 5, 2019

@Bopske are you using Show most recent posts at the top in topic view. ?

@Bopske

This comment has been minimized.

Copy link
Author

commented May 6, 2019

Not sure what you are asking. We use the SSI function in TinyPortal recent topics. That;s where the issue occurs...

@jdarwood007

This comment has been minimized.

Copy link
Member

commented May 6, 2019

Can you verify that the log_topics contains the correct information for the topic you are testing? It should have the correct message id for the relevant member and topic.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.