Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

11 errors after installing mod #93

Closed
frandominguez03 opened this issue Aug 14, 2018 · 9 comments

Comments

@frandominguez03
Copy link
Member

commented Aug 14, 2018

Using latest commit of SMF 2.1: SimpleMachines/SMF2.1@95a5a1d

Got 11 errors in the log after installing the mod;
screenshot_1
screenshot_2
screenshot_3

Is backtrace needed?

@jdarwood007

This comment has been minimized.

Copy link
Member

commented Aug 18, 2018

This is actually a SMF bug. SimpleMachines/SMF2.1#4926

Not sure what we can do to work around it yet.

@SugarD-x

This comment has been minimized.

Copy link

commented Feb 7, 2019

This is still present with SMF 2.1 RC1 also, although it generated 13 of them for me using the latest repository files for SimpleDesk.

@frandominguez03

This comment has been minimized.

Copy link
Member Author

commented Feb 7, 2019

Could you actually install the mod? I remember trying a few days ago and not being able to. I'll try again when I can.

@SugarD-x

This comment has been minimized.

Copy link

commented Feb 7, 2019

I was, however I had to go back to the Package Manager and do it again. If you upload it and try to install it directly, it just shows an install page with blank actions and an install button that does nothing. I'm not sure if this is an emulation bug in SMF 2.1 RC1, or an issue with SimpleDesk.

@frandominguez03

This comment has been minimized.

Copy link
Member Author

commented Feb 7, 2019

I'm not sure, but that's probably because there are no rules for installing it with SMF 2.1 RC1, as in package-info.xml:

https://github.com/SimpleDesk/SimpleDesk/blob/e94e0cff46611728234da5243f1be639039b8498/package-info.xml#L17

I haven't digged, so I'm probably wrong

@SugarD-x

This comment has been minimized.

Copy link

commented Feb 7, 2019

I'm not sure, but that's probably because there are no rules for installing it with SMF 2.1 RC1, as in package-info.xml:

SimpleDesk/package-info.xml

Line 17 in e94e0cf

I haven't digged, so I'm probably wrong

Ah, that could definitely explain it! I opened a bug report for that particular issue, (#99), so hopefully that is something that simple.

@jdarwood007

This comment has been minimized.

Copy link
Member

commented Feb 10, 2019

I've got a fix issued up to SMF repo that should clear this up by doing a silent ignore of hooks during package install/removal. If it merges, it will be in the next RC.

@jdarwood007 jdarwood007 self-assigned this Feb 10, 2019

@SugarD-x

This comment has been minimized.

Copy link

commented Feb 12, 2019

Awesome! It is definitely still present in SMF 2.1 RC1 with the latest SimpleDesk repo, so it'll be nice once they have that fixed. The spam is quite worrisome if you don't know what is going on. xD

@jdarwood007

This comment has been minimized.

Copy link
Member

commented Feb 16, 2019

The SMF repo merged these changes. I will close this, it will be fixed in the next SMF release. It can be verified by using the git version of SMF 2.1.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.