Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Allow perl-5.8.1 #3

Merged
merged 1 commit into from Feb 5, 2013

Conversation

Projects
None yet
2 participants
Contributor

mithun commented Feb 2, 2013

I've made a few changes to replace 5.10.1 features with those that will work with 5.8.1.

$work is a mix of RHEL5 and Windows - an environment where P9Y::PT is very useful (and better than Proc::PT). However RHEL5 is still stuck on perl-5.8.8.

Owner

SineSwiper commented Feb 5, 2013

Ugh, 2007... Figured I could shoot 5.8 at the kneecaps, but it looks like it's still getting some use here and there. I made some comments to the commits for changes. Also, can you also merge the commit down to one?

@mithun mithun Allow distribution to be used at least perl-5.8.8
- Updated P9Y::ProcessTable to use `if/else` instead of `for/when` syntax
- Updated OS specific modules to use `my` instead of `state`
- Stop using sanity since it requires perl-5.10.1.
    Rather use the default pragma that sanity loads

update minting profile to generate 5.8.1 compatible makefile

fix makefil template

Removed perltidy closing comments. Updated to require at least perl-5.8.8
61bf3fa
Contributor

mithun commented Feb 5, 2013

Done

@SineSwiper SineSwiper added a commit that referenced this pull request Feb 5, 2013

@SineSwiper SineSwiper Merge pull request #3 from mithun/master
Allow perl-5.8.1
a59226f

@SineSwiper SineSwiper merged commit a59226f into SineSwiper:master Feb 5, 2013

1 check failed

default The Travis build could not complete due to an error
Details
Owner

SineSwiper commented Feb 5, 2013

Awesome. I'll merge this and cut a dev release, just in case.

Contributor

mithun commented Feb 6, 2013

Thanks!

But it looks like dzil is sneaking in a 5.8.9 requirement. I thought I updated the dist.ini - unless I did something wrong.

This sort of defeats the purpose of this pull request :( ...

Owner

SineSwiper commented Feb 7, 2013

Probably something on PrereqsClean. I'll troubleshoot.

Owner

SineSwiper commented Feb 7, 2013

Found it:

[@Prereqs/PrereqsClean] {Pass 1: Core} Module utf8 v1.70.0 is only found in core Perl; adding Perl v5.8.9 requirement

Downgrade the version or just remove the utf8 requirement.

Contributor

mithun commented Feb 8, 2013

I couldn't find any explicit mention of utf8's version in the distribution.

It looks like the PreReq scanner assumes the version of utf8 found on your machine - v1.07 was first included in perl-5.8.9. perl-5.8.8 has utf8 v1.06.

Anyways, I've removed the utf8 pre-req as you recommended. New pull request in #5 .

Owner

SineSwiper commented Feb 13, 2013

Nah, looks like it was @minimumprereqs had minimum_year set too high, so it was stuffing the version for the 2008 utf8. Corrected the dist.ini and I'm releasing another dev version.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment